Excel - BUSCAR.SI diferenciando 0 (cero) de 00 (doble cero)

   
Vista:
Imágen de perfil de Juan

BUSCAR.SI diferenciando 0 (cero) de 00 (doble cero)

Publicado por Juan juanpvarela@gmail.com (1 intervención) el 26/02/2018 03:40:56
Saludos...
Rango de celdas A1:F6 formato texto con valores aleatorios: 00, 0, 1,2, ..., 36 (ruleta).
Columna G con valores: 00, 0, 1,2, ..., 36
Columna H con fórmula BUSCAR.SI para contar cada valor en el rango:
=CONTAR.SI($A$1:$F$6;G1)
...
=CONTAR.SI($A$1:$F$6;G38)

Problema: la formula agrupa "0" y "00" como iguales.
Intenté resolver (sin éxito):
- Agregando fórmula TEXTO a la condición de CONTAR.SI.
- Cambiando formato de rango a personalizado con cero a la izquierda ("00")

En la imagen adjunta
Resultado obtenido:
00: 4
0 : 4
Resultado esperado:
00: 3
0 : 1

Alguna pista?
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de wordexperto.com

BUSCAR.SI diferenciando 0 (cero) de 00 (doble cero)

Publicado por wordexperto.com (1458 intervenciones) el 26/02/2018 13:43:23
Usa una Tabla dinámica, que no falla.
https://wordexperto.com/


Captura
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
Imágen de perfil de Ignacio

BUSCAR.SI diferenciando 0 (cero) de 00 (doble cero)

Publicado por Ignacio (99 intervenciones) el 27/02/2018 01:12:05
Hola:

No puedo ver la imagen pero de acuerdo a lo que comentas te dejo un ejemplo, utilizando un rango auxiliar en la Hoja2.

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Revisar política de publicidad