Excel - Ultima celda diferente a ...

   
Vista:

Ultima celda diferente a ...

Publicado por Mishakely (3 intervenciones) el 28/02/2018 20:41:22
Buenas tardes compañeros,

Tengo una duda que llevo tiempo intentando y no he conseguido sonsacar.

Necesito que en una columna de Texto, el Excel pueda buscarme la ultima palabra de la columna pero que no sea cierta palabra.

Un exemplo.

- Quiero buscar la ultima celda diferente de "Blanco"
- La columna es la siguiente

Gris
Negro
Azul --> Objetivo a conseguir.
Blanco
Blanco

El resultado deberia ser: "Azul"
Pero solo consigo que me salga la ultima columna que es "Blanco"

Alguien podria ayudarme?
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Ignacio

Ultima celda diferente a ...

Publicado por Ignacio (122 intervenciones) el 28/02/2018 22:40:54
Hola:

Prueba con esto:

1
=INDICE(A1:A5,MAX(FILA(A1:A5)*(A1:A5<>"blanco")))

Es matricial (ctrl+shift+enter)

Mi separador de argumentois es la "," si el tuyo es otro cambialo.

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de John Jairo V.

Ultima celda diferente a ...

Publicado por John Jairo V. (4 intervenciones) el 28/02/2018 22:55:24
¡Hola, a ambos!

Otra opción puede ser (introducción normal):
1
=BUSCAR(2;1/(A1:A5<>"Blanco");A1:A5)

Nota: Mi separador de argumentos es ";". Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema. ¡Bendiciones!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Ultima celda diferente a ...

Publicado por Mishakely (3 intervenciones) el 01/03/2018 08:53:49
Gracias por la ayuda, pero lo he probado y me ha salido los siguientes resultados.

1a Opcion. Me salio "Blanco", cuando era justo la opcion que hay que descartar
2o Opcion. me salio #VALUE

Ya no se como hacerlo :(
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Ignacio

Ultima celda diferente a ...

Publicado por Ignacio (122 intervenciones) el 01/03/2018 15:21:33
Hola..

Las dos fórmulas funcionan bien

Te te dejo el archivo adjunto. Recuerda que la primera es matricial y debes darle ctrl+shift+enter.

lo que tienes que hacer en cualquiera de las dos es modificar los rangos de acuerdo a tus registros..

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Ultima celda diferente a ...

Publicado por Mishakely (3 intervenciones) el 01/03/2018 15:58:14
Lo he probado en mi Excel, y no consigo que me de resultado.

No se si es por el Rango o por si falla por tener espacios en blanco o similar.

Adjunto el Excel que ando usando.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Revisar política de publicidad