Excel - web - sumaproducto por condiciones de fechas

 
Vista:
Imágen de perfil de SIDIEVORA
Val: 24
Ha disminuido 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

web - sumaproducto por condiciones de fechas

Publicado por SIDIEVORA (14 intervenciones) el 03/08/2018 01:57:02
ocupo el sumaproducto, con rangos de fechas a consultar, la segunda solamente se pide y la primera dependiendo del mes iniciará en el dia 1 de ese mes (siempre)

NOTA: ANEXO EL ARCHIVO DE EXCEL

FECHA A CONSULTAR 03-ene
DIA Oro Minado Grado de autenticidad
01-ene 1,613 1.568
02-ene 50,000 1.600
03-ene 1,400 1.599
04-ene 4,500 1.500
05-feb 3,900 1.610
12-feb 55,000 1.590
20-feb 40,000 1.561

EJEMPLO #
1 SI tecleo la fecha a consultar 3 de enero:
ocupo el sumaproducto de la celda B con la C
RESULTADO SERIA ---------> 1.599
2 SI tecleo la fecha a consultar 12 de FEBRERO
ocupo el sumaproducto de la celda B con la C
RESULTADO SERIA ---------> 1.591

¿Cómo le hago para que tome como referencia primero la fecha a consultar de la celda C3?
¿Cómo le hago que dependiendo del mes que teclee, me dé el rango del dia 1ero de ese mes hasta el dia de la fecha consultada?

ejemplo
1 3 de enero, me daría 1, 2 y 3 de enero solamente
2 12 de febrero, me daría 5 y 12 de febrero solamente


NOTA: ANEXO EL ARCHIVO DE EXCEL
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Antoni Masana
Val: 3.891
Plata
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

web - sumaproducto por condiciones de fechas

Publicado por Antoni Masana (1334 intervenciones) el 03/08/2018 08:39:19
Para la primera pregunta la respuesta es:

1
=BUSCARV(C1;A3:C9;3;FALSO)

NOTA: Toma la fecha de referencia de C1 y no de C3

Para la segunda pregunta:

1
=SUMAR.SI.CONJUNTO(C3:C9;A3:A9;">="&J13;A3:A9;"<="&J14)

Donde:
J13 es la celda con la fecha desde Ejemplo: 01/02/2018
J14 es la celda con la fecha hasta. Ejemplo: 15/02/2018

Saludos.
\\//_
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de SIDIEVORA
Val: 24
Ha disminuido 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

web - sumaproducto por condiciones de fechas

Publicado por SIDIEVORA (14 intervenciones) el 04/08/2018 02:17:47
Buenas tardes Maestro Antoni Masana
sALUDOS desde Sinaloa, México

la respuesta a la primer pregunta is se logra el resultado

pero lo que ocupo para la segunda no es el =SUMAR.SI.CONJUNTO, es la SUMAPRODUCTO...

por ejemplo si la fecha que capturó el usuario es 12 de febrero
¿Cómo le hago que dependiendo del mes que teclee, me dé el rango del dia 1ero de ese mes hasta el dia de la fecha consultada?

Esto es que detecte la fecha la computadora si tecleo por ejemplo 12 de febrero. (este seria el tope de rango en fecha) e iniciaría
el 1eo de febrero..
Seria la suma producto del 1 de febrero al 12 de febrero

muchas gracias por su siempre valiosa ayuda..
espero su respuesta
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Antoni Masana
Val: 3.891
Plata
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

web - sumaproducto por condiciones de fechas

Publicado por Antoni Masana (1334 intervenciones) el 05/08/2018 00:17:16
Si el usuario pone la fecha 12/2/2018 y siguiendo el ejemplo el resultado es 3.2 la formula a aplicar es SUMAR.SI.CONJUNTO .

La formula SUMAPRODUCTO solo tendría sentido si el calculo fuese:

1
( 3.900 * 1,610 ) + ( 55.000 * 1,590 )

Que no es el caso.

Para calcular la fecha de primer día del mes de la fecha introducida (supongamos en la celda E3) seria esta la formula:

1
=E3 - DIA(E3) + 1

Ahora suponenos que en C2 tenemos la fecha del primer día del mes, en C3 la fecha del usuario y en C4 tendremos la suma con esta formula:

1
=SUMAR.SI.CONJUNTO(C:C ; A:A ; ">=" & E2 ; A:A ; "<=" & E3)

Si no es eso lo que necesitas deberías aportar algún ejemplo para entenderlo mejor.

Saludos.
\\//_
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
2
Comentar
Imágen de perfil de SIDIEVORA
Val: 24
Ha disminuido 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

web - sumaproducto por condiciones de fechas

Publicado por SIDIEVORA (14 intervenciones) el 07/08/2018 01:23:29
Musica gracias mi estimado
lo logre con su ayuda..
implemente otrós códigos complementados por los suyos..
primero hice la suma
=SUMAPRODUCTO(('Captura actual diaria'!$A$3:$A$367>=$F$5) * ('Captura actual diaria'!$A$3:$A$367<=$B$2) * 'Captura actual diaria'!$C$3:$C$367 * 'Captura actual diaria'!$D$3:$D$367)
segundo
la suma conjunto
=SUMAR.SI.CONJUNTO( 'Captura actual diaria'!$C$3:$C$367,'Captura actual diaria'!$A$3:$A$367,">="&$F$5,'Captura actual diaria'!$A$3:$A$367,"<="&$B$2)

y al finalizar la division
=$A$8/$B$8

muchas gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar