Excel - extraer texto si una cadena contiene una u otra palabra

 
Vista:
sin imagen de perfil
Val: 9
Ha aumentado su posición en 104 puestos en Excel (en relación al último mes)
Gráfica de Excel

extraer texto si una cadena contiene una u otra palabra

Publicado por carlos (13 intervenciones) el 07/09/2018 12:34:07
Hola me gustaría saber como extraer en una celda el contenido que hay en otra si contiene una determinada palabra clave u otra.

Ejemplo

A
1Maria Garcia Jimenez
2Pedro Lopez Garcia
3Samuel Perez Perez
4Sofia Cristo Almodóvar

La función tendría que recuperarme en otra celda B 1 el nombre de MARIA GARCIA JIMENEZ por contener Garcia o por Contener Jimenez y en la celda B2 el de Pedro Lopez Garcia por contener Garcia.


Muchas gracias,
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Antoni Masana
Val: 4.146
Plata
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

extraer texto si una cadena contiene una u otra palabra

Publicado por Antoni Masana (1456 intervenciones) el 07/09/2018 13:31:17
La formula seria esta:

1
=SI.ERROR(SI(O(ENCONTRAR($D$1;A1)>0;ENCONTRAR($D$1;A1)>0);A1;"");"")

Adjunto ejemplo

Saludos.
\\//_
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar