Excel - Devolver texto si celda contiene un año concreto

 
Vista:
sin imagen de perfil
Val: 9
Ha aumentado su posición en 105 puestos en Excel (en relación al último mes)
Gráfica de Excel

Devolver texto si celda contiene un año concreto

Publicado por CARLOS (13 intervenciones) el 11/12/2018 12:19:15
Quisiera saber si hay una formula que me devuelva un Texto concreto si la fecha de otra celda contiene un año especifico. Ej.

A1 B1
12/12/19 PENDIENTE
12/12/18
14/03/19 PENDIENTE



En este caso si aparece el año 2019 debe devolver en B1 el texto pendiente

Gracias,
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Antoni Masana
Val: 4.150
Plata
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Devolver texto si celda contiene un año concreto

Publicado por Antoni Masana (1457 intervenciones) el 11/12/2018 12:47:26
Como no se en función de que define el año voy a poner dos opciones.

A piñón fijo.
1
=SI(Año(A1)>2018 ; "Pendiente" ; "")

Mirando el calendario:
1
=SI(Año(A1)>Año(Hoy()) ; "Pendiente" ; "")


Saludos.
\\//_
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil

Devolver texto si celda contiene un año concreto

Publicado por Gustavo (1 intervención) el 22/12/2018 19:36:46
Yo suelo usar la opción "a piñon fijo", encuentro que es más fácil y suelo usarla para todas mis tablas.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Antoni Masana
Val: 4.150
Plata
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Devolver texto si celda contiene un año concreto

Publicado por Antoni Masana (1457 intervenciones) el 23/12/2018 00:45:02
Me parece bien que utilices la opción de "a piñón fijo" pero los años van irremediablemente pasando y en algún momento entradas fechas del 2019, 2020, 2021, a partir de ahora todas serán pendientes porque todas serán mayores de 2018 y en algún momento deberas cambiar el año en las formulas.

Si el cambio de año no se produce al mismo ritmo que el cambio natural, prueba otra opción y es poner el año en una celda y en la condición hacer referencia a esa celda.

Pongamos que el año lo pones en la Celda Z1, las formulas quedan así:

1
=SI(Año(A1)>$Z$1 ; "Pendiente" ; "")

Saludos.
\\//
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar