Excel - Obtener valor de primera celda de columna correspondiente a un número de entre una tabla

 
Vista:
sin imagen de perfil
Val: 11
Ha disminuido 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

Obtener valor de primera celda de columna correspondiente a un número de entre una tabla

Publicado por Raúl (3 intervenciones) el 06/03/2019 19:58:59
Hola.

Tengo una tabla de excel en la que quiero buscar un número para que el valor que me aporte la celda, sea el del "encabezado" (texto), de la columna en la que se encuentre el número que busco.

Por ejemplo:

A            B            C            D

12          9            10           8

6           4,5           5             4

4             3            3,3        2,6

Quiero obtener el valor A, B, C o D de los 6 números mayores de la tabla (que obtengo con =K.ESIMO.MAYOR), en función de la columna en que se encuentren, esto es, necesito que me proporcione automáticamente las letras del "encabezado" correspondiente a la columna donde esté el número:

12        A

10        C

9          B

8          D

6          A

5          C

¿Es posible?

Adjunto hoja de excel con más detalle de lo que necesito.

No sé si me he explicado. Gracias de antemano.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Ignacio
Val: 718
Bronce
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Obtener valor de primera celda de columna correspondiente a un número de entre una tabla

Publicado por Ignacio (197 intervenciones) el 06/03/2019 20:20:33
Hola:

Checa el adjunto:

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
sin imagen de perfil
Val: 11
Ha disminuido 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

Obtener valor de primera celda de columna correspondiente a un número de entre una tabla

Publicado por Raúl (3 intervenciones) el 07/03/2019 09:33:49
Muchas gracias Ignacio.
Me ha sido de gran utilidad. Por lo que veo es complejo y no podría haberlo averiguado.
Permíteme que "abuse" y te haga otra pregunta. Si los primeros datos de la fila los traigo vinculados de una hoja distinta, pero quiero que sólo me aparezca el número en el supuesto de que sea > al 7,5% y en caso contrario que aparezca 0 o no me aparezca nada, ¿qué puedo hacer?
Mando el ejemplo desarrollado sobre el mismo supuesto.
Muchas gracias de nuevo y en esta ocasión de antemano.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Ignacio
Val: 718
Bronce
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Obtener valor de primera celda de columna correspondiente a un número de entre una tabla

Publicado por Ignacio (197 intervenciones) el 07/03/2019 16:28:10
En D2

1
=SI(Hoja1!D3<7.5%,0,Hoja1!D2)


Mi separador de argumentos es la "," cámbialo si utilizas otro..

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
Imágen de perfil de wordexperto.com
Val: 6.019
Oro
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Obtener valor de primera celda de columna correspondiente a un número de entre una tabla

Publicado por wordexperto.com (2053 intervenciones) el 06/03/2019 20:49:57
Hola a todos:
Creo que esta fórmula es suficiente: =INDICE($B$1:$E$1;;COINCIDIR(MAX(B2:E2);B2:E2;0)).
https://wordexperto.com/
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Cacho R
Val: 93
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Obtener valor de primera celda de columna correspondiente a un número de entre una tabla

Publicado por Cacho R (57 intervenciones) el 06/03/2019 21:09:22

Hola!
Ten en cuenta que tu afirmación: - "... que obtengo con =K.ESIMO.MAYOR ..." (o cualquier otra fórmula equivalente) sólo sería acertada si no tuvieses valores repetidos.

- En el ejemplo que has publicado aquí: los tienes.
- En tu Excel: ¡no los tienes!

Según este factor será la solución más apropiada: a "pura fórmula" o con el auxilio de una macro.

¿Comentarías cuál es tu situación real?...

Saludos, Mario (Cacho) R

Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
sin imagen de perfil
Val: 11
Ha disminuido 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

Obtener valor de primera celda de columna correspondiente a un número de entre una tabla

Publicado por Raúl (3 intervenciones) el 07/03/2019 09:32:22
Muchas gracias Cacho R. Lo cierto es que el supuesto en el que estoy trabajando permite que dos valores sean iguales y, en efecto, ya no me valdría K.ESIMO.MAYOR, con lo que ahora me has descubierto otro problema. Es poco probable que se repitan, pero es posible.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Cacho R
Val: 93
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Obtener valor de primera celda de columna correspondiente a un número de entre una tabla

Publicado por Cacho R (57 intervenciones) el 07/03/2019 20:05:54
.

En tal caso intenta con:

Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar