Excel - Para cualquier tipo de dato

 
Vista:

Para cualquier tipo de dato

Publicado por PENÚLTIMO Y ANTEPENÚLTIMO VALOR DE UNA FILA (2 intervenciones) el 21/03/2019 02:17:10
Hola

Me pueden ayudar, necesito obtener el penúltimo y antepenúltimo dato de una fila sin importar el tipo de dato que sea
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Ignacio
Val: 722
Bronce
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Para cualquier tipo de dato

Publicado por Ignacio (205 intervenciones) el 21/03/2019 17:52:24
Hola:

Para un rango de A2:I2

Penúltimo:
1
=INDICE(A2:I2,,K.ESIMO.MAYOR(INDICE((A2:I2<>"")*COLUMNA(A2:I2),),2))

Antepenúltimo:
1
=INDICE(A2:I2,,K.ESIMO.MAYOR(INDICE((A2:I2<>"")*COLUMNA(A2:I2),),3))


Mi separador de argumentos es la "," cámbialo si utilizas otro.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

Para cualquier tipo de dato

Publicado por Susy Niflo (2 intervenciones) el 21/03/2019 18:30:16
Hola

Muchas gracias, funciona perfecto.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar