Excel - Hallar entre varios rangos

 
Vista:

Hallar entre varios rangos

Publicado por Jonathan (2 intervenciones) el 08/04/2019 23:27:21
Buen día

Tengo 3 bloques de tarifa
De 0 a 300 es un costo
De 300.01 a 600 es otro
De 600.01 a 1500 es otro.

Ya tengo la siguiente fórmula :

=SI(ESERROR(HALLAR("300",b5)),250)
Entonces en la celda b5 a fuerza le tengo que poner 300 para que me devuelva el valor de 250.

Lo que requiero es que yo ponga cualquier número del 0 al 300 para que me dé el mismo valor 250,
Así ponga 200 , 199, o 250 siempre me devolverá ese valor por qué está dentro del rango de tarifa ..

Espero y me halla explicado y poder contar con una solución de acuerdo a sus buenos conocimientos
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Ignacio
Val: 705
Bronce
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Hallar entre varios rangos

Publicado por Ignacio (205 intervenciones) el 08/04/2019 23:37:08
Hola:

Checa el adjunto.

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Ignacio
Val: 705
Bronce
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Hallar entre varios rangos

Publicado por Ignacio (205 intervenciones) el 08/04/2019 23:53:36
Cambia la fórmula por esta:

1
=SI(BUSCARV(B5,E3:F5,2)>=B5,BUSCARV(B5,E3:G5,3),"Fuera de rango)")


Mi separador de argumentos es la "," cámbialo si utilizas otro..
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de wordexperto.com
Val: 6.455
Oro
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Hallar entre varios rangos

Publicado por wordexperto.com (2221 intervenciones) el 09/04/2019 08:32:48
Hola a todos:
Aquí tienes otras dos soluciones. Las tarifas de 240 y 230 son inventadas. Pon las tuyas.
Con un rango auxiliar y buscarv verdadero
Directamente con elegir+coincidir: =ELEGIR(COINCIDIR(D2;{0;300;600};1);250;240;230)
https://wordexperto.com/


Captura
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar