Excel - Mejorar la Función SI con Función SI y BuscarV

 
Vista:
Imágen de perfil de JOSE LUIS
Val: 121
Ha disminuido 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

Mejorar la Función SI con Función SI y BuscarV

Publicado por JOSE LUIS (58 intervenciones) el 16/05/2019 01:36:34
Buenas tardes a los integrantes de este prestigioso foro, en esta ocasión recurro a uds para solicitar su apoyo en como mejorar las siguientes formulas que detallo a continuación:

FORMULA EN CELDA P2

Cuando la fórmula es evaluada

=SI(G2="";"";SI(O(G2=BASE_AUXILIAR!$B$8;G2=BASE_AUXILIAR!$B$9;G2=BASE_AUXILIAR!$B$10;G2=BASE_AUXILIAR!$B$11;G2=BASE_AUXILIAR!$B$12;G2=BASE_AUXILIAR!$B$13;G2=BASE_AUXILIAR!$B$14;G2=BASE_AUXILIAR!$B$15;G2=BASE_AUXILIAR!$B$16;G2=BASE_AUXILIAR!$B$17;G2=BASE_AUXILIAR!$B$18;G2=BASE_AUXILIAR!$B$19=BASE_AUXILIAR!$B$20=BASE_AUXILIAR!$B$21=BASE_AUXILIAR!$B$22=BASE_AUXILIAR!$B$23=BASE_AUXILIAR!$B$24=BASE_AUXILIAR!$B$25=BASE_AUXILIAR!$B$26=BASE_AUXILIAR!$B$27=BASE_AUXILIAR!$B$28=BASE_AUXILIAR!$B$29=BASE_AUXILIAR!$B$30=BASE_AUXILIAR!$B$31=BASE_AUXILIAR!$B$32=BASE_AUXILIAR!$B$33=BASE_AUXILIAR!$B$34=BASE_AUXILIAR!$B$35=BASE_AUXILIAR!$B$36=BASE_AUXILIAR!$B$37=BASE_AUXILIAR!$B$38=BASE_AUXILIAR!$B$39=BASE_AUXILIAR!$B$40=BASE_AUXILIAR!$B$41=BASE_AUXILIAR!$B$42=BASE_AUXILIAR!$B$43=BASE_AUXILIAR!$B$44=BASE_AUXILIAR!$B$45=BASE_AUXILIAR!$B$46=BASE_AUXILIAR!$B$47);0;E2))

G2 no contiene los criterios: 01: WINCHERO (hoja base_auxiliar B2) -- 02: WINCHERO T (hoja base_auxiliar B3) -- 03: MURO (hoja base_auxiliar B4) -- 04: MURO T hoja base_auxiliar B5) -- 05 BODEGUERO (hoja base_auxiliar B6) -- 06 BODEGUERO T (hoja base_auxiliar B7)

Asigna el valor de la celda E2, y para el resto de criterios desde la hoja base_auxiliar (B8:B47) será 0 (cero)

formula desarrollada en celda Q2: =SI.ERROR(SI(G2="";"";SI(G2=AAA;BUSCARV(G2;BASE_AUXILIAR!$B$8:$B$47;1;FALSO);));E2)

Utilice:

Nombre de Rango: AAA (base_auxiliar D2:D7) y para BUSCARV (base_auxiliar B8:B47) y se hay mejor opción de mejora acepto ideas.

FORMULA EN CELDA S2

Cuando la fórmula es evaluada:

=SI(G2="";"";SI(O(G2=BASE_AUXILIAR!$B$2;G2=BASE_AUXILIAR!$B$4;G2=BASE_AUXILIAR!$B$6;G2=BASE_AUXILIAR!$B$8;G2=BASE_AUXILIAR!$B$9;G2=BASE_AUXILIAR!$B$10;G2=BASE_AUXILIAR!$B$11;G2=BASE_AUXILIAR!$B$12;G2=BASE_AUXILIAR!$B$13;G2=BASE_AUXILIAR!$B$14;G2=BASE_AUXILIAR!$B$15;G2=BASE_AUXILIAR!$B$16;G2=BASE_AUXILIAR!$B$17;G2=BASE_AUXILIAR!$B$18;G2=BASE_AUXILIAR!$B$19;G2=BASE_AUXILIAR!$B$20;G2=BASE_AUXILIAR!$BF$21;G2=BASE_AUXILIAR!$B$22;G2=BASE_AUXILIAR!$B$23;G2=BASE_AUXILIAR!$B$24;G2=BASE_AUXILIAR!$B$25;G2=BASE_AUXILIAR!$B$26;G2=BASE_AUXILIAR!$B$27;G2=BASE_AUXILIAR!$B$28;G2=BASE_AUXILIAR!$B$29;G2=BASE_AUXILIAR!$B$30;G2=BASE_AUXILIAR!$B$31;G2=BASE_AUXILIAR!$B$32;G2=BASE_AUXILIAR!$B$33;G2=BASE_AUXILIAR!$B$34;G2=BASE_AUXILIAR!$B$35;G2=BASE_AUXILIAR!$B$36;G2=BASE_AUXILIAR!$B$37;G2=BASE_AUXILIAR!$B$38;G2=BASE_AUXILIAR!$B$39;G2=BASE_AUXILIAR!$B$40;G2=BASE_AUXILIAR!$B$41;G2=BASE_AUXILIAR!$B$42;G2=BASE_AUXILIAR!$B$43;G2=BASE_AUXILIAR!$B$44;G2=BASE_AUXILIAR!$B$45;G2=BASE_AUXILIAR!$B$46;G2=BASE_AUXILIAR!$B$47);0;K2))

G2 contiene los criterios: 02: WINCHERO T (hoja base_auxiliar B3) -- 04: MURO T (hoja base_auxiliar B5) -- 06 BODEGUERO T (hoja base_auxiliar B7)

Asigna el valor de la celda K2, y para el resto de criterios desde la hoja base_auxiliar (B8:B47) será 0 (cero)

Y es ahí donde quisiera usar Función SI y Función BUSCARV como se aprecia la formula en celda S2 o quizás haya otro método.

Desde ya agradazco su apoyo y colaboración.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Antoni Masana
Val: 4.151
Plata
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Mejorar la Función SI con Función SI y BuscarV

Publicado por Antoni Masana (1459 intervenciones) el 16/05/2019 08:21:50
Te voy a hacer varios comentarios sobre las formulas que has usado:

En las columnas M, N y O no tiene sentido que pongas:

1
=SI(C2="";"";C2)

por que consigues el mismo resultado:

1
=C2

a parte de encontrarle sentido a repetir la formula.


En la formula de la columna S hay un error:

1
;G2=BASE_AUXILIAR!$BF$21;


Sobra la Fórmula de la columna P esta mal:

1
2
3
4
5
6
7
8
9
10
11
12
=SI(G2="";"";SI(O(G2=BASE_AUXILIAR!$B$8;
                  G2=BASE_AUXILIAR!$B$9;
                  G2=BASE_AUXILIAR!$B$10;
                  G2=BASE_AUXILIAR!$B$11;
                  G2=BASE_AUXILIAR!$B$12;
                  G2=BASE_AUXILIAR!$B$13;
                  G2=BASE_AUXILIAR!$B$14;
                  G2=BASE_AUXILIAR!$B$15;
                  G2=BASE_AUXILIAR!$B$16;
                  G2=BASE_AUXILIAR!$B$17;
                  G2=BASE_AUXILIAR!$B$18;
                  G2=BASE_AUXILIAR!$B$19=BASE_AUXILIAR!$B$20=BASE_AUXILIAR!$B$21=BASE...);0;E2))


Y por lo que deduzco de las formulas que has puesto una opción es esta:

1
=SI.ERROR(SI(BUSCARV(G2;BASE_AUXILIAR!$B$2:$B$47;1;FALSO)=G2;0;E2);E2)

Si encuentras el texto de la columna G2 en la Base Auxiliar pon CERO y en caso contrario pon E2.

Saludos.
\\//_
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
Imágen de perfil de JOSE LUIS
Val: 121
Ha disminuido 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

Mejorar la Función SI con Función SI y BuscarV

Publicado por JOSE LUIS (58 intervenciones) el 16/05/2019 22:16:47
Buenas tardes Antoni Masana, efectivamente a los comentarios indicados y seguido las recomendaciones ya he subsanado esos datos y la formula

1
=SI.ERROR(SI(BUSCARV(G2;BASE_AUXILIAR!$B$8:$B$47;1;FALSO)=G2;0;E2);E2)

quedo muy bien y bajo ese mismo criterio aplique para la otra formula solo variando la condiciones de busqueda


1
=SI.ERROR(SI(BUSCARV(G2;BASE_AUXILIAR!$F$2:$F$44;1;FALSO)=G2;0;K2);K2)

Saludos y gracias por aporte.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar