Excel - Mantener valor calculado en la celda, si cambia la condición.

 
Vista:
sin imagen de perfil
Val: 22
Ha disminuido 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

Mantener valor calculado en la celda, si cambia la condición.

Publicado por Eduardo (7 intervenciones) el 28/10/2019 20:19:46
Buenas tardes
Tengo una consulta, si existe un método o forma, para mantener fija la fecha final en la celda si cambio la condición.
Les explico, En la celda H si ingreso 1 aumenta en una hora, la hora final, si ingreso 2 aumenta a dos horas la hora final y así sucesivamente.
Pero si ingreso S/T que es equivalente a "Sin Tiempo", en hora final me refleja que esta sin tiempo, pero la fecha final la borra porque S/T no es ningún número que ayude para calcular la fecha final, por ende me arroja #¡VALOR!.

ayuda

Existe un método de poner una condición, que al momento de ingresar S/T, la fecha final final antes calculada se mantenga fija y avance si es que avanzan los días.
o se mantenga mientras esta S/T hasta que se vuelva a ingresar nuevamente un numero.
desde ya muchas gracias
Saludos cordiales
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Alfredo
Val: 361
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Mantener valor calculado en la celda, si cambia la condición.

Publicado por Alfredo (100 intervenciones) el 28/10/2019 20:39:52
Hola Eduardo

Si ingresas en la celda E3 (Fecha final) una condición

1
=SI(H3="S/T",C3,(C3+F3)+0/24)

Prueba y nos comentas

Saludos desde México
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
2
Comentar
sin imagen de perfil
Val: 22
Ha disminuido 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

Mantener valor calculado en la celda, si cambia la condición.

Publicado por Eduardo (7 intervenciones) el 28/10/2019 21:57:59
Muchas gracias Alfredo, funciono muy bien.
Tengo una ultima consulta.

ayuda2

Si se mantiene la condición S/T y pasamos al siguiente día. Como se puede pasar al siguiente día de manera automática Fecha final.
Se puede incluir una condicion HOY() o AHORA(). para que pueda hacer dicho cambio.

Desde ya muchas gracias por la ayuda anterior.
Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Alfredo
Val: 361
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Mantener valor calculado en la celda, si cambia la condición.

Publicado por Alfredo (100 intervenciones) el 28/10/2019 22:39:30
Hola de nuevo Eduardo

A ver, prueba con esto

1
=SI(H3="S/T",SI(C3<HOY(),HOY(),C3),(C3+F3)+0/24)
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
sin imagen de perfil
Val: 22
Ha disminuido 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

Mantener valor calculado en la celda, si cambia la condición.

Publicado por Eduardo (7 intervenciones) el 06/11/2019 13:15:43
muchas gracias Alfredo, fue de gran ayuda tus comentarios
Saludos cordiales
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar