Excel - Compara columnas y devolver un valor

 
Vista:
sin imagen de perfil
Val: 12
Ha aumentado su posición en 5 puestos en Excel (en relación al último mes)
Gráfica de Excel

Compara columnas y devolver un valor

Publicado por Rafael (4 intervenciones) el 16/12/2019 18:57:22
Hola buenas tardes, necesito vuestra ayuda para saber si es posible conseguir que se comparen las columnas E y F con las A y B, y si son coincidentes las dos, que la cifra de C pase a G.

Por ejemplo, Carla Matemáticas, situará en G la cifra 12.

Si fuese Carla Física no pondría nada en G.

Adjunto captura del ejemplo.

Gracias a todos.

Saludos,
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Ignacio
Val: 698
Bronce
Ha disminuido 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

Compara columnas y devolver un valor

Publicado por Ignacio (205 intervenciones) el 16/12/2019 20:11:32
Hola:

Puedes utilizar en G2

1
=INDICE($C$2:$C$20,COINCIDIR(E2&F2,$A$2:$A$20&$B$2:$B$20,0))

Es fórmula matricial (CTRL+SHIFT+ENTER)


Mi separador de argumentos es la "," cámbialo si utilizas otro.

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
sin imagen de perfil
Val: 12
Ha aumentado su posición en 5 puestos en Excel (en relación al último mes)
Gráfica de Excel

Compara columnas y devolver un valor

Publicado por Rafael (4 intervenciones) el 16/12/2019 23:57:10
Muchas gracias Ignacio, es lo que necesitaba.

Saludos,
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de wordexperto.com
Val: 6.484
Oro
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Compara columnas y devolver un valor

Publicado por wordexperto.com (2236 intervenciones) el 16/12/2019 20:31:42
Hola Rafael:
Necesitas una columna auxiliar y buscarv.
https://www.youtube.com/channel/UCxgRcbeR2q4PpE1Pgft74Iw


Captura
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
sin imagen de perfil
Val: 12
Ha aumentado su posición en 5 puestos en Excel (en relación al último mes)
Gráfica de Excel

Compara columnas y devolver un valor

Publicado por Rafael (4 intervenciones) el 16/12/2019 23:57:57
Muchas gracias por tu ayuda. Ya lo tengo mucho más claro.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Antoni Masana
Val: 4.161
Plata
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Compara columnas y devolver un valor

Publicado por Antoni Masana (1488 intervenciones) el 16/12/2019 20:33:06
La próxima vez sube un libro, que es más fácil probar la fórmula.

Esta es la formula que debes colocar en la celda G2

1
=SI.ERROR(INDICE($C$2:$C$21 ; COINCIDIR(E2&F2 ; $A$2:$A$21&$B$2:$B$21 ; 0)) ; "?")

Nota: La fórmula anterior es matricial, por lo que deberás ingresar la combinación de teclas [Control] + [Shift] + [Enter].

El resultado en la ventana de formulas debe ser este:

1
{=SI.ERROR(INDICE($C$2:$C$21 ; COINCIDIR(E2&F2 ; $A$2:$A$21&$B$2:$B$21; 0)) ; "?")}

Si no funciona cambia los PUNTO_Y_COMA por COMA. Y por ultimo arrastra la fórmula al resto de celdas de la columna.

Saludos.
\\//_
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
sin imagen de perfil
Val: 12
Ha aumentado su posición en 5 puestos en Excel (en relación al último mes)
Gráfica de Excel

Compara columnas y devolver un valor

Publicado por Rafael (4 intervenciones) el 16/12/2019 23:58:27
Muchas gracias Antonio, poco a poco iré aprendiendo.

Saludos,
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar