Excel - Función que repita otras funciones

 
Vista:
sin imagen de perfil
Val: 33
Ha aumentado su posición en 99 puestos en Excel (en relación al último mes)
Gráfica de Excel

Función que repita otras funciones

Publicado por Ángel (13 intervenciones) el 12/04/2020 23:15:24
Buenos días.



Captura

Supongamos que tengo una tabla como la de la imagen, y quiero sumar en cada casilla de de "Suma hora #" el total de cada hora.

Mi idea era hacer "=SUMA(BUSCARV("Hora 1";C3:F5;4;FALSO);BUSCARV("Hora 1";C7:F9;4;FALSO);...)", pero al final esta formula se vuelve increiblemente grande. Hay alguna manera de que excel repita la misma fomula cambiado cada vez a que rango de celdas se refiere? O hay alguna otra funcion que haga el trabajo de BUSCARV varias veces?


Muchas gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de wordexperto.com
Val: 6.484
Oro
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Función que repita otras funciones

Publicado por wordexperto.com (2230 intervenciones) el 13/04/2020 10:18:03
Si pones horas reales y quitas las filas en blanco te lo hace Excel automáticamente con una Tabla dinámica.
https://www.youtube.com/playlist?list=PLF1OL9sNXkSyOJETR9ST8xjwjFj9WrkME
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de wordexperto.com
Val: 6.484
Oro
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Función que repita otras funciones

Publicado por wordexperto.com (2230 intervenciones) el 13/04/2020 10:22:36
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 33
Ha aumentado su posición en 99 puestos en Excel (en relación al último mes)
Gráfica de Excel

Función que repita otras funciones

Publicado por Ángel (13 intervenciones) el 13/04/2020 11:52:59
Muchisimas gracias, no conocía las tablas dinámicas.

Captura1

Captura

Ahora, yo en la hoja de datos tengo muchos datos de varios días, y la tabla dinámica en vez de sumar las horas iguales con las horas iguales me lo agrupa por días, hay alguna manera de evitar que esto pase?

Vale nada, lo he solucionado cambiando el formato de las horas escribiendo "Hora #"
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de wordexperto.com
Val: 6.484
Oro
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Función que repita otras funciones

Publicado por wordexperto.com (2230 intervenciones) el 13/04/2020 12:00:47
Puedes seleccionar qué agrupa y qué no agrupa. También puedes desmarcar los campos agrupados que no necesites: https://www.youtube.com/watch?v=_rO3efrka6s&list=PLF1OL9sNXkSyOJETR9ST8xjwjFj9WrkME&index=7&t=0s
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar