Excel - Función que repita otras funciones

 
Vista:
sin imagen de perfil
Val: 37
Ha aumentado 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

Función que repita otras funciones

Publicado por Ángel (14 intervenciones) el 12/04/2020 23:15:24
Buenos días.



Captura

Supongamos que tengo una tabla como la de la imagen, y quiero sumar en cada casilla de de "Suma hora #" el total de cada hora.

Mi idea era hacer "=SUMA(BUSCARV("Hora 1";C3:F5;4;FALSO);BUSCARV("Hora 1";C7:F9;4;FALSO);...)", pero al final esta formula se vuelve increiblemente grande. Hay alguna manera de que excel repita la misma fomula cambiado cada vez a que rango de celdas se refiere? O hay alguna otra funcion que haga el trabajo de BUSCARV varias veces?


Muchas gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
sin imagen de perfil
Val: 37
Ha aumentado 1 puesto en Excel (en relación al último mes)
Gráfica de Excel

Función que repita otras funciones

Publicado por Ángel (14 intervenciones) el 13/04/2020 11:52:59
Muchisimas gracias, no conocía las tablas dinámicas.

Captura1

Captura

Ahora, yo en la hoja de datos tengo muchos datos de varios días, y la tabla dinámica en vez de sumar las horas iguales con las horas iguales me lo agrupa por días, hay alguna manera de evitar que esto pase?

Vale nada, lo he solucionado cambiando el formato de las horas escribiendo "Hora #"
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar