Excel - Transformar letras en números y sacar promedio

 
Vista:

Transformar letras en números y sacar promedio

Publicado por Jhon (1 intervención) el 16/04/2020 05:22:34
Buenas noches, he colocado literales en Excel y cada literal o letra tiene un valor. He conseguido que las sume pero quiero que las promedie directamente por el número de casillas que tengan letra. Es como una hoja de evaluación de escuela donde pones letras pero te tiene que dar un promedio. Ejemplo
Tengo 15 casillas para poner notas desde la C3 hasta P3 colocando letras con los siguientes valores
I=1, F=2, K=3, C=4 y J=5
Quiero que cuando yo vaya colocando la letra en algunas casillas de ese rango, el programa las sume y las promedie (en la casilla Q3) por el número de casillas que tengan letras.
Utilicé esta fórmula pero solo da la suma total y no las promedia entres el número de notas

=SUMA(C3:P3)+CONTAR.SI(C3:P3;"I")*1+CONTAR.SI(C3:P3;"F")*2+CONTAR.SI(C3:P3;"K")*3+CONTAR.SI(C3:P3;"C")*4+CONTAR.SI(C3:P3;"J")*5
QUE DEBO HACER PARA PROMEDIAR?
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de wordexperto.com
Val: 6.484
Oro
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Transformar letras en números y sacar promedio

Publicado por wordexperto.com (2230 intervenciones) el 16/04/2020 10:56:28
Ya son ganas de complicar las cosas, Jhon:
Usa directamente los números y/o haz los cálculos con Tablas dinámicas: https://www.youtube.com/playlist?list=PLF1OL9sNXkSyOJETR9ST8xjwjFj9WrkME


Captura
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar