Excel - QUITAR LETRAS DEL NIE EN EXCEL 2013

 
Vista:
sin imagen de perfil
Val: 9
Ha disminuido su posición en 3 puestos en Excel (en relación al último mes)
Gráfica de Excel

QUITAR LETRAS DEL NIE EN EXCEL 2013

Publicado por Carlos (13 intervenciones) el 18/05/2020 16:42:00
Buenas tardes me gustaría que alguien me indicase si hay alguna función para eliminar las letras de una cadena de caracteres como por ejemplo las de un NIE

Ejemplo

X7992846F
78965487J

Debería quedar

7992846
78965487

Es decir debe detectar las letras y eliminarlas porque en las distintas celdas de la columna hay DNI' y NIE's


Gracias,
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de wordexperto.com
Val: 6.484
Oro
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

QUITAR LETRAS DEL NIE EN EXCEL 2013

Publicado por wordexperto.com (2230 intervenciones) el 18/05/2020 21:29:58
Hola Carlos:
Esta función hace lo que quieres: =SI(ESNUMERO(VALOR(IZQUIERDA(A1)));IZQUIERDA(A1;8);DERECHA(A1;8))
https://www.youtube.com/playlist?list=PLF1OL9sNXkSyOJETR9ST8xjwjFj9WrkME
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Andres Leonardo
Val: 3.913
Plata
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

QUITAR LETRAS DEL NIE EN EXCEL 2013

Publicado por Andres Leonardo (1457 intervenciones) el 18/05/2020 22:38:37
Hola estoy viendo lo que publica Jose pues lo voy a probar,,,, en mi caso

Pues Cuando me toco hacer algo hice esto ...

Por formula


ExtraerNumeroFormula

Por UDF
ExtraerNumeroUDF

Aqui esta la Funcion , espero te ayude
1
2
3
4
5
6
7
Public Function ExtraeNumeros(r As Range) As String
    For i = 1 To Len(r.Value)
        If IsNumeric(Mid(r.Value, i, 1)) Then
            ExtraeNumeros = ExtraeNumeros & Mid(r.Value, i, 1)
        End If
    Next i
End Function
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar