Excel - ASOCIAR IMAGENES A UNA LISTA DE 2 RESULTADOS

 
Vista:
sin imagen de perfil
Val: 200
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

ASOCIAR IMAGENES A UNA LISTA DE 2 RESULTADOS

Publicado por Quico (93 intervenciones) el 25/05/2020 09:16:06
Hola, me gustaría encontrar una solución para asociar 2 imágenes distintas en función de la elección de 2 resultados posibles DE UNA LISTA.

Si veis el excel adjunto, en la celda E4 tengo una casilla de selección LISTA con 2 resultados: 'OK' y 'NOK'.
Justo al lado, tengo una celda combinada para darle mayor tamaño (B2)

Bueno, pues lo que intento es que B2 me muestre una imagen según la elección de la lista (sus 2 opciones).
Para ello, en creado en AA y AB una minitabla con los valores 'OK' y 'NOK' y ambas imágenes.....

¡Pero NO SE hacer esta asociación de imagen logo al resultado seleccionado.
He visto por internet cosas que hacen referencia a =INDICE(xxxxxxxxx;COINCIDIR(yyyyyyy))
Pero no he conseguido hacerlo funcionar.

¿Alguien podría ayudarme?
Gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de RET
Val: 90
Ha aumentado su posición en 27 puestos en Excel (en relación al último mes)
Gráfica de Excel

ASOCIAR IMAGENES A UNA LISTA DE 2 RESULTADOS

Publicado por RET (26 intervenciones) el 26/05/2020 09:31:10
Hola,

He movido tus imágenes al recuadro que tienes en B2 y he insertado un pequeño código VBA en la hoja de forma que si seleccionas OK trae arriba el icono verde y en caso contrario el rojo.

1
2
3
4
5
6
7
8
9
10
11
12
Private Sub Worksheet_Change(ByVal Target As Range)
    If Target.Row <> 4 Or Target.Column <> 5 Then Exit Sub
 
    If Hoja2.Cells(4, 5).Value = "OK" Then
        ActiveSheet.Shapes.Range(Array("Picture 9")).Select
        Selection.ShapeRange.ZOrder msoBringToFront
    Else
        ActiveSheet.Shapes.Range(Array("Picture 7")).Select
        Selection.ShapeRange.ZOrder msoBringToFront
    End If
    Target.Select
End Sub

Esto es lo que querías, no?

IMF_RET
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar