Excel - Referencia a otro libro excel de forma dinámica.

 
Vista:

Referencia a otro libro excel de forma dinámica.

Publicado por Javier (6 intervenciones) el 06/08/2020 12:00:53
Buenos días!!!
Lo primero gracias a todos aquellos que por lo menos me lean

Tengo un fichero excel con datos. (Datos.xls)

Ahora tengo otro fichero con los formularios para rellenar con los datos del anterior fichero (Formularios.xls)

Lo que quiero conseguir es introduciendo en una celda del formularios.xls el nombre de una hoja (un número en mi caso) me devuelva el valor guardado en una celda en concreto de la hoja cuyo nombre haya indicado del fichero datos.xls.

Un ejemplo:

File: DATOS.XLS
Sheet1: 1, celda A1 = GUATEMALA
Sheet2: 2, celda A1 = BERLIN
Sheet3: 3, celda A1 = MOSCU
....

Y ahora en file: FORMULARIOS.XLS
Quiero poner en la celda A1 un número 1, 2, 3, ... y que me devuelta el valor asociado (GUATEMALA, BELON O MSOCU en estos casos)

He hecho pruebas con INDIRECTO y creo que van por ahí los tiros, pero cuando trato de reemplazar el valor "fijo" para asociarlo al "dinámico" casca.

1
=INDIRECTO("'[Datos.xls]1716'!$B$6")
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Antoni Masana
Val: 4.115
Plata
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Referencia a otro libro excel de forma dinámica.

Publicado por Antoni Masana (1504 intervenciones) el 07/08/2020 15:21:25
Una posibilidad

Celda A1 - pones el numero

Celda C1 - Referencia a: =[Datos.xlsx]hoja1:A1
Celda C2 - Referencia a: =[Datos.xlsx]hoja2:A1
Celda C3 - Referencia a: =[Datos.xlsx]hoja3:A1

Celda B1 - Fórmula: =INDICE(C1:C3;A1;1)
o
Celda B1 - Fórmula: =SI.ERROR(INDICE(C1:C3;A1;1); "VALOR INCORRECTO")

Saludos.
\\//_
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Referencia a otro libro excel de forma dinámica.

Publicado por Javier (6 intervenciones) el 12/08/2020 07:08:56
Gracias por la aportación, pero no se "ajusta" a mi necesidad.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de RET
Val: 102
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Referencia a otro libro excel de forma dinámica.

Publicado por RET (27 intervenciones) el 11/08/2020 15:40:15
Vas bien con INDIRECTO. Lo que tienes que hacer es crear la referencia variable con CONCATENAR.

1
=INDIRECTO(CONCATENAR("'[Datos.xls]";A1;"'!$B$6"))


IMF_RET
https://InformaticaMuyFacil.com
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Referencia a otro libro excel de forma dinámica.

Publicado por Javier (6 intervenciones) el 12/08/2020 07:09:42
Perfecto, esto sí soluciona mi problema. La verdad es que vista la solución era lógica... pero yo no daba con ella.
Muchas gracias.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar