Excel - ERROR Insertar Formula en Excel (Macro)

 
Vista:
sin imagen de perfil
Val: 8
Ha aumentado su posición en 4 puestos en Excel (en relación al último mes)
Gráfica de Excel

ERROR Insertar Formula en Excel (Macro)

Publicado por andre (4 intervenciones) el 25/12/2020 20:08:05
La funciones que se usan son BUSCARV y COINCIDIR y se insertan correctamente pero me sale el error de NOMBRE,pero aun asi presiono en la celda donde se inserto la formula y hago ENTER y ahi recien me arroja el resultado;Alguna sugerencia o dato que no me haya dado cuenta,gracias de antemano
Archivo para que lo revisen ,gracias

1
2
3
4
5
6
7
8
9
10
11
Sub FormulaExcel()
 
With Hoja1.Range("D11").CurrentRegion
 
    UltimaFila = .Rows(.Rows.Count).Row
 
    'MsgBox UltimaFila
    Hoja1.Range("E12:E" & UltimaFila).Formula = "=SI.ERROR(BUSCARV($D12,$A$9:$B$20,COINCIDIR(E$11,$A$8:$B$8,0),FALSE),0)"
End With
 
End Sub
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Antoni Masana
Val: 4.908
Oro
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

ERROR Insertar Formula en Excel (Macro)

Publicado por Antoni Masana (2488 intervenciones) el 25/12/2020 21:23:11
En la macro escribes la formula en castellano y en las macros se deben escribir en ingles y Excel la traduce según el idioma que tengas.

Es decir la macro funciona en cualquier idioma que tengas el Excel, Castellano, Frances, Ingles, Alemán, portugués o cualquier otro, cuando te la muestra el Excel se traduce según el idioma.

Otro tema son las referencias a las celdas al crear una formula desde una macro.

Como no voy a darte un curso del tema te sugiero que hagas lo siguiente:

- GRABAR MACRO.
- Escribir la formula en una celda.
- FINALIZAR GRABAR.
- Mirar que ha escrito Excel.

Y veras por que te falla y lo que tienes que poner en la macro.

Saludos.
\\//_
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar