Excel - Estoy haciendo una aplicación para saber quienes cumplen años el día de mañana

 
Vista:
sin imagen de perfil
Val: 49
Ha disminuido su posición en 3 puestos en Excel (en relación al último mes)
Gráfica de Excel

Estoy haciendo una aplicación para saber quienes cumplen años el día de mañana

Publicado por Albert (88 intervenciones) el 26/03/2021 18:19:59
buenas tardes foreros,
estoy haciendo una aplicación para saber quienes cumplen años el día de mañana lo estoy intentando hacer con la siguiente formula pero no la hago bien

1
{=SI.ERROR(INDICE(Cumple;K.ESIMO.MENOR(SI(ENTERO(INDICE(Cumple;0;1))=$F$3;COINCIDIR(DIA(Cumple);MES(Cumple);0);"");FILA(#¡REF!));COLUMNA(#¡REF!));"")}

se trata de hacer coincidir el día y el mes pero no me sale, os adjunto una copia sin datos por lo de la ley de privacidad

Gracias por vuestra ayuda
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de wordexperto.com
Val: 6.373
Oro
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Estoy haciendo una aplicación para saber quienes cumplen años el día de mañana

Publicado por wordexperto.com (2804 intervenciones) el 26/03/2021 19:06:30
Hola Albert:
Puedes complicarlo todo lo que quieras, pero solo necesitas filtrar por fecha en la base de datos. Añade una columna con el día de la fecha de nacimiento y filtra por ese día. También puedes hacerlo con una tabla dinámica.
https://www.youtube.com/channel/UCxgRcbeR2q4PpE1Pgft74Iw


Captura
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Antoni Masana
Val: 4.908
Oro
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Estoy haciendo una aplicación para saber quienes cumplen años el día de mañana

Publicado por Antoni Masana (2488 intervenciones) el 26/03/2021 19:12:20
En la hoja clientes veo esta formula y no se que esSIFECHA() no me sale como formula de Excel

1
=SI(B6="";"";SIFECHA(B6;HOY();"Y"))

En la hoja Cumpleaños hay cosas que no veo o ser ver:

- ¿Que es Cumple?
- ¿Que rango define Cumple?
- ¿Cuál es el parámetro de la función FILA()?
- ¿Cuál es el parámetro de la función COLUMNA()?

1
2
3
=SI.ERROR(INDICE(Cumple;K.ESIMO.MENOR(SI(ENTERO(INDICE(Cumple;0;1))=$F$3 ;
                      COINCIDIR(DIA(Cumple);MES(Cumple);0);"");
                      FILA(#¡REF!));COLUMNA(#¡REF!));"")

Saludos.
\\//_
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 49
Ha disminuido su posición en 3 puestos en Excel (en relación al último mes)
Gráfica de Excel

Estoy haciendo una aplicación para saber quienes cumplen años el día de mañana

Publicado por Albert (88 intervenciones) el 26/03/2021 19:32:12
Gracias a los dos por vuestras respuesta

Antoni, el sifecha cuenta los años desde el nacimiento hasta la fecha de hoy, ahora me doy cuenta que al copiar la formula ha salido mal en el excel esta bien y se refiere a la celda donde esta el nombre, la formula he intentado adaptarla de esta que te adjunto que es de una aplicación de agenda de tareas,en esta busca la fecha completa incluyendo en año y en la que yo necesito ahora es sin año, espero explicarme bien


1
=SI.ERROR(INDICE(Citas;K.ESIMO.MENOR(SI(ENTERO(INDICE(Citas;0;1))=$J$7;COINCIDIR(FILA(Citas);FILA(Citas);0);"");FILA(A1));COLUMNA(A1));"")

Gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 49
Ha disminuido su posición en 3 puestos en Excel (en relación al último mes)
Gráfica de Excel

Estoy haciendo una aplicación para saber quienes cumplen años el día de mañana

Publicado por Albert (88 intervenciones) el 01/04/2021 19:08:15
buenas tardes, ya lo he resuelto, en vez de usar tablas he usado directamente la pagina, os adjunto el codigo por si alguien lo necesita


1
=SI(FILAS(J$11:J11)>J$8;"";INDICE(Cumple!$C$2:$C$65536;K.ESIMO.MENOR(SI((Cumple!$I$2:$I$65536=DIA(L$5)&"/"&MES(L$5));FILA(Cumple!$I$2:$I$65536)-FILA(Cumple!$C$2)+1);FILAS(Calendario!J$11:J11))))

Gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de wordexperto.com
Val: 6.373
Oro
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

Estoy haciendo una aplicación para saber quienes cumplen años el día de mañana

Publicado por wordexperto.com (2804 intervenciones) el 01/04/2021 19:30:04
Qué quieres que te diga, comparado con la fórmula de la Tabla dinámica, o del filtro, que es esta: , si, no me he equivocado, quiero decir: (nada), no tiene comparación, pero cada cuál es ...
Moraleja, olvídate de fórmulas complejas y usa Tablas dinámicas, solo si quieres.
https://www.youtube.com/channel/UCxgRcbeR2q4PpE1Pgft74Iw
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar