Excel - buscar el el texto más parecido

 
Vista:
Imágen de perfil de celia
Val: 761
Bronce
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

buscar el el texto más parecido

Publicado por celia (418 intervenciones) el 31/08/2021 12:54:34
Hola

Ya estoy con otro enredo, jeje.

No encuentro un fórmula que encuentre el texto más parecido de uan lista.

En el ejemplo, si en A1 escribo "galletas" que encontrara "gall3taz" por ser el más parecido de la lista y que devolviera su precio en A2.

Muchas gracias

lista
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de celia
Val: 761
Bronce
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

buscar el el texto más parecido

Publicado por celia (418 intervenciones) el 02/09/2021 10:42:18
Encontré esta fórmula que funciona en parte =BUSCARV(A2;A4:B14;2;1)

El problema es que si la lista no está en orden alfabético falla.
Si se añade, por ejemplo, "azúcar" al final de la lista no sé porqué encuentra ese último producto como válido
PRECIOS
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Antoni Masana
Val: 4.908
Oro
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

buscar el el texto más parecido

Publicado por Antoni Masana (1892 intervenciones) el 03/09/2021 16:49:36
Para que te funcione tienes que tener la lista ordenada.

Saludos.
\\//_
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar