Excel - AYUDA CODIGO EXCEL

 
Vista:

AYUDA CODIGO EXCEL

Publicado por Facundo (1 intervención) el 27/11/2023 20:34:11
En mi columna B esta la subcategoria que esta dividida en 'Gasto' e 'Importe', despues en mi columna D esta el importe, marcado por numeros, yo quiero que en mi columna G se sumen todos los importes cuando en la B sea 'Gasto' y que en mi columna H se sumen todos los importes cuando en la B sea 'importe'

Apreciaria muchisimo la ayuda
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Antoni Masana
Val: 4.908
Oro
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

AYUDA CODIGO EXCEL

Publicado por Antoni Masana (2499 intervenciones) el 29/11/2023 15:58:20
No entiendo cuando dices que:

- " en mi columna G se sumen todos los importes cuando en la B sea 'Gasto' "
- " en mi columna H se sumen todos los importes cuando en la B sea 'Importe' "

Por que las sumas normalmente están en una sola celda. Las formulas son estas

1
2
Columna G: =SUMAR.SI(B:B;"=Gasto";C:C)
Columna H: =SUMAR.SI(B:B;"=Importe";C:C)

Si lo que quieres es esto:

1
2
3
4
5
6
7
8
9
10
11
12
13
|  A       B      C     D     E     F     G     H
+-----+--------+-----+-----+-----+-----+-----+-----+
|     | Gast   | 100 |     |     |     | 100 |     |
|     | Import |   1 |     |     |     |     |  1  |
|     | Gast   | 100 |     |     |     | 200 |     |
|     | Import |   1 |     |     |     |     |  2  |
|     | Import |   1 |     |     |     |     |  3  |
|     | Gast   | 100 |     |     |     | 300 |     |
|     | Import |   1 |     |     |     |     |  4  |
|     | Gast   | 100 |     |     |     | 400 |     |
|     | Import |   1 |     |     |     |     |  5  |
|     | Import |   1 |     |     |     |     |  6  |
|     | Gast   | 100 |     |     |     | 500 |     |

La formula sería esta

1
2
Columna G: =SI(B2="Gasto";SUMAR.SI(B$2:B2;"=Gasto";C$2:C2);"")
Columna H: =SI(B2="Gasto";"";SUMAR.SI(B$2:B2;"=Importe";C$2:C2))



Saludos.
\\//_
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar