Excel - Fusionar dos formualas

 
Vista:

Fusionar dos formualas

Publicado por yannick (12 intervenciones) el 04/07/2007 16:36:27
Hola hace ya una semana estoy con un problema de formulas lo que quiero es hacer es fusionar estas condisiones:

SI A es igual a C entonces hacer esto:
- Si D es igual a 0 o D es igual a ? entonces:
Si es verdadero poner "ICOD"
Si es falso poner "COD"
- De lo contrario hacer esto:
Si B es igual a C entonces:
Si es verdadero hacer:
Si F es igual a 0 o F es igual ? o G es igual a 0 o G es igual a ?
Si es verdadero "ICOD"
Si es falso "COD"
Si es falso: ""

Otra condision:

Si H es distinto a 0 o I es distinto a 0 entonces:
- Si es verdadero "CODC"
- Si es falso:
Si H es igual a 0 y I es igual a 0
Si es verdadero: " "
Si es falso: no hacer nada

Estas serian las formulas
=SI( A3=C3, SI(O(D3=0,D3="?", E3=0,D3="?"),"ICOD", "COD" ), SI(B3=C3, SI(O(F3=0,F3="?",G3=0,G3="?" ),"ICOD","COD" ), "" ) )

=SI(O(H4<>0,I4<>0),"CODC",SI(Y(H4=0,I4=0),"",""))

Como lo podria hacer???

Desde ya muchas gracias!!!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Abraham Valencia
Val: 319
Ha mantenido su posición en Excel (en relación al último mes)
Gráfica de Excel

RE:Fusionar dos formualas

Publicado por Abraham Valencia (2415 intervenciones) el 04/07/2007 18:41:49
Segun las pautas que has dado:

=SI(A3=C3,SI(O(D3=o,D3="?"),"ICOD","COD"),SI(B3=C3,SI(O(F3=0,F3="?",G3=0,G3="?"),"ICOD","COD")))

PAra la otra, guiate de la que acabo de enviar.

Abraham
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Fusionar dos formualas

Publicado por Yannick (12 intervenciones) el 04/07/2007 20:05:10
Hola Abraham !

Si esa ya la habia sacado, el tema es fusionar esas dos condiciones(que a su vez tienen mas condiciones, pero hablemos de 1 y 2):


(1)
=SI( A3=C3, SI(O(D3=0,D3="?", E3=0,D3="?"),"ICOD", "COD" ), SI(B3=C3, SI(O(F3=0,F3="?",G3=0,G3="?" ),"ICOD","COD" ), "" ) )

(2)
=SI(O(H4<>0,I4<>0),"CODC",SI(Y(H4=0,I4=0),"",""))

Son distintas formulas, lo que yo quisiera seria esto:

SI A = C entonces hacer esto:

___ Si es verdadero : Si D=0 o D=? o E=0 o E=?
______ Si es verdadero poner "ICOD"
______ Si es falso : SI H<>0 o I<>0
_________ Si es verdadero poner "CODC"
_________ Si es falso : SI H=0 o I=0
____________ Si es verdadero poner "vacio"
____________ Si es falso poner "CALL"
___ Si es falso : B=C
______ Si es verdadero : Si F=0 o F=? o G=0 o G=?
_________ Si es verdadero poner "ICOD"
_________ Si es falso : SI H<>0 o I<>0
____________ Si es verdadero poner "CODC"
____________ Si es falso :SI H=0 o I=0
_______________ Si es verdadero poner "vacio"
_______________ Si es falso poner "CALL"
______ Si es falso: "vacio"

Algo asi serian... Gracias Abraham por tu respuesta espero que me puedas ayudarr.

Desde ya muchas gracias!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar