Excel - Diferencia entre matrices

 
Vista:

Diferencia entre matrices

Publicado por Aby (1 intervención) el 11/07/2007 00:47:35
Hola...!!! Que tal espero alguien pueda ayudarme, mi problemilla es este:

Tengo 2 matrices con datos y quiero que me excluya en otro apartado los datos que no coinciden, jeje no se si me explico bien, pero ahi va un ejemplo:

Matriz 1:
A B
MPRAFA12 ATA001
MPRAFB12 ATA002
MPRAFH14 ATA003
MPRAFD12 ATA004
MPRAFC12 ATA005

Matriz 2:
A B
MPRAFA12 ATAxxx
MPRAFB12 ATA002
MPRAFH14 ATA003
MPRAxxxx ATA004
MPRAFC12 ATA005

Y entonces este sería el resultado que quiero obtener:

A B
MPRAFA12 ATAxxx
MPRAxxxx ATA004

Que serian esos 2

Plisss ayuda... se los agradecere muchooo =)

(ki_bray@hotmail.com)
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
sin imagen de perfil

RE:Diferencia entre matrices

Publicado por jcs (494 intervenciones) el 11/07/2007 11:25:05
Muy buenas,

A ver si te vale esto:

Supongamos que los valores de la matriz 1 los tienes en la Hoja1 a partir de la línea 1 y los de la matriz 2 en la Hoja2, también a partir de la línea 1.

En esta Hoja2 en la celda C1 copia esta fórmula
=SI(O(ESERROR(COINCIDIR(A1;Hoja1!A1:A5;0)); ESERROR(COINCIDIR(B1;Hoja1!B1:B5;0)));A1;"")

y en la celda D1
=SI(O(ESERROR(COINCIDIR(A1;Hoja1!A1:A5;0)); ESERROR(COINCIDIR(B1;Hoja1!B1:B5;0)));B1;"")

Te aparecerán con resultados todos aquellos que sean distintos. Si luego los quieres seguidos, siempre puedes copiar esas dos columnas, hacer un pegado especial (valores) en otro sitio y luego ordenarlos.

Un saludo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar