FoxPro/Visual FoxPro - Se me borran los métodos al Actualizar un Grid

 
Vista:

Se me borran los métodos al Actualizar un Grid

Publicado por Martín Maglianesi (6 intervenciones) el 16/07/2000 00:00:00
Hola a Todos
En algún lugar he leído sobre este problema pero no me acuerdo su solución. La cuestión es que tengo un Grid basado en una DBF temporal que armo con una Select de SQL. Lo que pretendo hacer es por ejemplo, que cuando se haga click en el Header de cualquiera de sus columnas, la Select genere nuevamente el archivo temporal, pero ordenado en base a esa columna. Similar al comportamiento del Explorador de Windows. El tema está que cuando vuelvo a asignarle en el RecordSource el archivo temporal, se me borra todo el código que tengo escrito en los métodos del Grid.
Si alguien sabe la respuesta a este problema, o cree que se puede armar de una manera distinta, desde ya estaré muy agradecido me digan cómo.
Por el momento lo he solucionado colacando Botones que simulan el Header encima de cada uno de ellos, pero no es la solución perfecta :(
Desde ya, muchas gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Se me borran los métodos al Actualizar un Grid

Publicado por Marcos Jara (194 intervenciones) el 17/07/2000 00:00:00
Sabes amigo... te recomiendo que hagas lo mismo que estas haciendo ahora, pero
con una consulta .qpr, funciona mejor que escribiendo el de INSTRUCCION SQL, a mi ,
personalmente cuando tengo este tipo de problemas con la instruccion sql, lo hago,
con el .qpr como te dije y funciona perfecto.... SUERTE..
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar