PHP - No trae contenido de página

   
Vista:

No trae contenido de página

Publicado por Ulises (5 intervenciones) el 11/06/2017 00:47:37
Hola,

Estoy tratando de extraer datos desde un página web pública, pero al aplicar file_get_contents no me trae la pagina que quiero sino que me manda a la pagina inicial del sitio, lo que aplico es muy simple:

1
echo file_get_contents("http://seia.sea.gob.cl/busqueda/buscarTitularConsultorAction.php?busca=false&externo=1&tipo=TITULARES&subtipo=EMPRESA&nombre_rut=&nombre=&presentacion=AMBOS&id_tipoexpediente=0&_paginador_refresh=1&_paginador_fila_actual=2");

Debería traerme una tabla con una lista de personas...

Podrían darme una ayuda?

Slds y gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de kip

No trae contenido de página

Publicado por kip (862 intervenciones) el 11/06/2017 01:33:56
Hola, ingrese al enlace del cual intentas obtener los datos y me muestra que no soy USUARIO REGISTRADO, creo que no funciona porque talvez debes haber iniciado sesion para poder realizar busquedas y ademas veo tambien que la pagina tiene un error en su codigo ya que muestra un mensaje muy claro de este.

1
Fatal error: Call to a member function setFilaActual() on a non-object in /opt/seia/sitios/seiaprod/include/clases/paginador.inc on line 396

Quizas debido a esto es que no puede mostrar ningun dato.

Intenta contactar con ellos y tratar de averiguar porque no muestran los datos y avisarles de aquel error para que puedas continuar con tu proyecto.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

No trae contenido de página

Publicado por Ulises (5 intervenciones) el 11/06/2017 01:54:03
Gracias Kip por tu respuesta,

Efectivamente da un error, pero si tomas la dirección y la pegas en un navegador, si te trae datos... porqué funciona en el navegador y por código no?

Ahora bien, si tú ingresas este link que corresponde a las 10 primeras filas de la tabla, funciona:

http://seia.sea.gob.cl/busqueda/buscarTitularConsultorAction.php?busca=true&externo=1&tipo=CONSULTORES&subtipo=EMPRESA&nombre_rut=&nombre=&presentacion=AMBOS&id_tipoexpediente=&id_tipoexpediente=0

Pero si ingresas este otro, que son las siguientes 10 filas, no funciona:

http://seia.sea.gob.cl/busqueda/buscarTitularConsultorAction.php?busca=true&externo=1&tipo=CONSULTORES&subtipo=EMPRESA&nombre_rut=&nombre=&presentacion=AMBOS&id_tipoexpediente=0&_paginador_refresh=1&_paginador_fila_actual=2

y da el error mencionado por tí... entonces esa es mi pregunta, pq en el browser si funciona y en el código no?




Slds
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de kip

No trae contenido de página

Publicado por kip (862 intervenciones) el 11/06/2017 02:09:15
No, el error al que me refiero es ingresando por el navegador mira:

Screenshot_506

Parece ser un problema del codigo de la pagina, como te comente en el mensaje anterior.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

No trae contenido de página

Publicado por Ulises (5 intervenciones) el 11/06/2017 02:12:30
Kip,

Pega los dos link anteriores que di en la respuesta y prueba en el browser, verás que funcionan...

Gracias por tus respuestas...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Revisar política de publicidad