PHP - Subi pagina web a un host pero no me funciona el css.

   
Vista:
Imágen de perfil de facundo

Subi pagina web a un host pero no me funciona el css.

Publicado por facundo (185 intervenciones) el 11/11/2017 21:29:37
Hola como van?

Estoy armando una pagina y necesito subirla para probar algunas cosas antes de terminarla. Es la primera vez que subo una pagina y no tengo ni idea.. El tema es que en el servidor xampp local funciona bien, pero subida no funciona bien el css, por ejemplo faltan imagenes o hay partes que no estan, por ejemplo en inicio no se ve el footer pero en las demas si, aunqe sin las imagenes.


Alguien tiene idea por que puede ser? Es necesario que suba el codigo? No creo que sea eso porque en el xampp anda bien.

La pagina es esta http://stellaverduras.eshost.com.ar/index.php
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Subi pagina web a un host pero no me funciona el css.

Publicado por preguntas (20 intervenciones) el 11/11/2017 23:25:51
Lo mas probable es que haya fallado alguna linea de código en PHP y por eso no se completó tu página.

Si miras el código fuente de tu página, no está completa. No está escrita la parte del footer, ni siquiera el cierre de las etiquetas principales de HTML.

Esto es lo que hay:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
<!DOCTYPE html>
<html>
<head>
	<title>Inicio</title>
	<meta charset="utf-8"/>
	<link href="css/estilos2.css" rel="stylesheet" type="text/css"/>
</head>
<body>
 
	<header> </header>
 
 
 
	 <main>
 
         <hr id="hrMain">
 
         <nav>
            <!--<div id="barranav">
    <a href="index.php" class="nav"> INICIO </a>
    <a href="info.php" class="nav">Info de productos</a>
    <a href="recetas.php" class="nav">Recetas</a>
    <a href="contacto.php" class="nav">Contáctenos</a>
</div> -->
 
 
 
<ul class="nav">
    <li><a href="index.php"><b>INICIO</b></a> </li>
    <li> <a href="info.php">Info de productos</a>
        <ul class="s1">
            <li><a href="#">Donde se deshidratan las verduras?</a> </li>
            <li><a href="#">Tiene procesos quimicos o agregados?</a> </li>
            <li><a href="#">Instrucciones de uso</a> </li>
        </ul>
    </li>
    <li><a href="recetas.php">Recetas </a></li>
    <li><a href="contacto.php">Contactenos </a></li>
</ul>         </nav>
	  <hr>
         <br><br><br><br><br>
	    <center>
           <!-- <img src="images/verd2.jpg" id="imgMain"> -->
                   <p id="pindex"> Distribuidora oficial de productos ANACO valle del conlara.
                Empresa dedicada a la comercializacion de verduras deshidratadas listas para cocinar.<br>
                QUERES COMER SANO PERO NO TENES TIEMPO PARA PREPARAR LAS VERDURAS? ANACO VERDURAS FACIL Y RAPIDO <br>
                ................. Y DEMAS INFO QUE QUIERAS PONER</p>
 
 
                <h1 id="h1index">Texto &nbsp negocio &nbsp introduccion &nbsp  titulo &nbsp  encabezado</h1>
 
 
	 	   <div id
           ></div>

y el resto???????????????????????????
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

Subi pagina web a un host pero no me funciona el css.

Publicado por GILBERTO gsinstal@gmail.com (1 intervención) el 12/11/2017 03:20:52
Me parece que debería usar en cajas div css: el width:100%; en lugar de px; en css debes pones si es escalable:1:1; muy bonito tu sitio!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de facundo

Subi pagina web a un host pero no me funciona el css.

Publicado por facundo (185 intervenciones) el 12/11/2017 18:30:19
Hola gracias, si, pasa que recien estoy aprendiendo css y es el primer sitio que maqueto, responsive lo dejo para mas adelante..

Preguntas, gracias por responder, que puede ser lo que causa ese error en php? Tengo un require "footer.php", que si te fijas en las otras secciones como en info de productos o en contactenos funciona, de hecho en el xampp funciona todo bien en todas las paginas...
tampoco se ven las imagenes, la unica que se ve es la del header
la verdad no tengo ni idea que puede llegar a ser ya que es la primera vez que subo una pagina
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
-1
Comentar

Subi pagina web a un host pero no me funciona el css.

Publicado por daniel (18 intervenciones) el 13/11/2017 20:33:48
Hola, podrias agregar el codigo para hechar un vistaso, inspeccionando se ve este mensaje: Failed to load resource: the server responded with a status of 500 (Internal Server Error)
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de facundo

Subi pagina web a un host pero no me funciona el css.

Publicado por facundo (185 intervenciones) el 13/11/2017 21:42:06
Ya se resolvio gracias igual.

Era un problema con los permisos de usuario de la base de datos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de facundo

Subi pagina web a un host pero no me funciona el css.

Publicado por facundo (185 intervenciones) el 13/11/2017 21:49:37
http://stellaverduras.byethost6.com la cambie de host tambien
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Revisar política de publicidad