PHP - Códigos raros al guardar categoría en Prestashop

   
Vista:

Códigos raros al guardar categoría en Prestashop

Publicado por Panaceo (1 intervención) el 10/12/2017 09:50:25
Hola a todos;

Os cuento un problema que tengo con Prestashop. Lo pongo aquí porque no creo que sea del CMS, sino de la configuración del servidor.

Tengo un extrañísimo error al guardar el nombre o descripción de una categoría. También me ocurre con los productos. Algo que no me pasaba antes y que me pasa a raíz de haber hecho algún cambio en el servidor. Algunas categorías me aparecen correctamente codificadas, con sus tildes y sus ñ, pero si entro a modificar alguna y guardo, me la codifica mal.

Si desde la BD modifico la categoría que está incorrecta y la pongo bien, el problema desaparece. Pero si desde el backend entro de nuevo a esa categoría y guardo, vuelve a codificarla mal.

Y algo parecido me ocurre con el idioma.

Pensé que podría ser un problema de cotejamiento de la base de datos, así que cambié todas las tablas a utf8mb4 y actualicé MySQL.

Si la BD la vuelvo a utf8_spanish_ci, tampoco se soluciona el problema.

Espero que me podáis ayudar. Muchas gracias.

Info de mi Prestashop:

Versión de PrestaShop 1.6.1.17
Tema actual en uso transformer
Información del servidor Linux #1 SMP Fri Oct 28 09:48:26 CEST 2016 x86_64
Versión del software del servidor Apache
Versión de PHP 7.0.26
Límite de memoria 512M
Tiempo Máximo de ejecución 600
Versión de MySQL 10.2.11-MariaDB
Motor MySQL InnoDB
Controlador MySQL DbPDO
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder