PHP - Ejecutar Función CURL en PHP con PHP antiguo

   
Vista:

Ejecutar Función CURL en PHP con PHP antiguo

Publicado por enzzo (20 intervenciones) el 16/12/2017 12:30:43
Buenas, tengo un script de php que entre otras cosas usa curl para recoger datos de una web con un proxy específico. Funciona bien probando en mi pc en local pero al cargarla en el servidor no va, da un error de no reconocer la función curl. Es un servidor antiguo, Debian v3 y un php antiguo v5.1.1, así que será por eso, el problema es que no puedo hacer cambios grandes en ese servidor puesto que no soy el administrador. ¿Se os ocurre alguna solución?
Gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de xve

Ejecutar Función CURL en PHP con PHP antiguo

Publicado por xve (6548 intervenciones) el 17/12/2017 10:38:12
Tienes que instalar el paquete: php5-curl

1
apt-get install php5-curl
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Ejecutar Función CURL en PHP con PHP antiguo

Publicado por Enzzo (20 intervenciones) el 17/12/2017 10:47:27
Gracias xve, a ese paso llegué pero al lanzar ese comando parece que empieza a instalarlo pero luego lo aborta pero no tengo a mano el error exacto,
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de xve

Ejecutar Función CURL en PHP con PHP antiguo

Publicado por xve (6548 intervenciones) el 17/12/2017 19:49:37
Hola Enzzo, cuando tengas el error exacto indicanos, ok? recuerda que tiene que actualizar el repositorio como root:
1
2
apt-get update
apt-get install php5-curl
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Ejecutar Función CURL en PHP con PHP antiguo

Publicado por Enzzo (20 intervenciones) el 18/12/2017 09:58:51
Este es el fallo a ambos comandos:

apt-get update
Err http://non-us.debian.org woody/non-US/main Packages
404 Not Found
Ign http://non-us.debian.org woody/non-US/main Release
Err http://non-us.debian.org woody/non-US/contrib Packages
404 Not Found
Ign http://non-us.debian.org woody/non-US/contrib Release
Err http://non-us.debian.org woody/non-US/non-free Packages
404 Not Found
Ign http://non-us.debian.org woody/non-US/non-free Release
Err http://ftp.fr.debian.org sarge/main Packages
404 Not Found [IP: 212.27.32.66 80]
Err http://non-us.debian.org woody/non-US/main Sources
404 Not Found
Ign http://non-us.debian.org woody/non-US/main Release
Err http://non-us.debian.org woody/non-US/contrib Sources
404 Not Found
Ign http://non-us.debian.org woody/non-US/contrib Release
Ign http://ftp.fr.debian.org sarge/main Release
Err http://non-us.debian.org woody/non-US/non-free Sources
404 Not Found
Ign http://non-us.debian.org woody/non-US/non-free Release
Err http://security.debian.org woody/updates/main Packages
404 Not Found [IP: 212.211.132.250 80]
Ign http://security.debian.org woody/updates/main Release
Err http://security.debian.org woody/updates/contrib Packages
404 Not Found [IP: 212.211.132.250 80]
Ign http://security.debian.org woody/updates/contrib Release
Err http://security.debian.org woody/updates/non-free Packages
404 Not Found [IP: 212.211.132.250 80]
Ign http://security.debian.org woody/updates/non-free Release
Err http://ftp.fr.debian.org sarge/non-free Packages
404 Not Found [IP: 212.27.32.66 80]
Ign http://ftp.fr.debian.org sarge/non-free Release
Err http://ftp.fr.debian.org sarge/contrib Packages
404 Not Found [IP: 212.27.32.66 80]
Ign http://ftp.fr.debian.org sarge/contrib Release
Err http://ftp.fr.debian.org woody/main Sources
404 Not Found [IP: 212.27.32.66 80]
Ign http://ftp.fr.debian.org woody/main Release
Err http://ftp.fr.debian.org woody/non-free Sources
404 Not Found [IP: 212.27.32.66 80]
Ign http://ftp.fr.debian.org woody/non-free Release
Err http://ftp.fr.debian.org woody/contrib Sources
404 Not Found [IP: 212.27.32.66 80]
Ign http://ftp.fr.debian.org woody/contrib Release
Err http://ftp.fr.debian.org woody/main Sources
404 Not Found [IP: 212.27.32.66 80]
Ign http://ftp.fr.debian.org woody/main Release
Err http://ftp.fr.debian.org woody/non-free Sources
404 Not Found [IP: 212.27.32.66 80]
Ign http://ftp.fr.debian.org woody/non-free Release
Err http://ftp.fr.debian.org woody/contrib Sources
404 Not Found [IP: 212.27.32.66 80]
Ign http://ftp.fr.debian.org woody/contrib Release
Failed to fetch http://ftp.fr.debian.org/debian/dists/sarge/main/binary-i386/Packages 404 Not Found [IP: 212.27.32.66 80]
Failed to fetch http://ftp.fr.debian.org/debian/dists/sarge/non-free/binary-i386/Packages 404 Not Found [IP: 212.27.32.66 80]
Failed to fetch http://ftp.fr.debian.org/debian/dists/sarge/contrib/binary-i386/Packages 404 Not Found [IP: 212.27.32.66 80]
Failed to fetch http://ftp.fr.debian.org/debian/dists/woody/main/source/Sources 404 Not Found [IP: 212.27.32.66 80]
Failed to fetch http://ftp.fr.debian.org/debian/dists/woody/non-free/source/Sources 404 Not Found [IP: 212.27.32.66 80]
Failed to fetch http://ftp.fr.debian.org/debian/dists/woody/contrib/source/Sources 404 Not Found [IP: 212.27.32.66 80]
Failed to fetch http://non-us.debian.org/debian-non-US/dists/woody/non-US/main/binary-i386/Packages 404 Not Found
Failed to fetch http://non-us.debian.org/debian-non-US/dists/woody/non-US/contrib/binary-i386/Packages 404 Not Found
Failed to fetch http://non-us.debian.org/debian-non-US/dists/woody/non-US/non-free/binary-i386/Packages 404 Not Found
Failed to fetch http://non-us.debian.org/debian-non-US/dists/woody/non-US/main/source/Sources 404 Not Found
Failed to fetch http://non-us.debian.org/debian-non-US/dists/woody/non-US/contrib/source/Sources 404 Not Found
Failed to fetch http://non-us.debian.org/debian-non-US/dists/woody/non-US/non-free/source/Sources 404 Not Found
Failed to fetch http://security.debian.org/dists/woody/updates/main/binary-i386/Packages 404 Not Found [IP: 212.211.132.250 80]
Failed to fetch http://security.debian.org/dists/woody/updates/contrib/binary-i386/Packages 404 Not Found [IP: 212.211.132.250 80]
Failed to fetch http://security.debian.org/dists/woody/updates/non-free/binary-i386/Packages 404 Not Found [IP: 212.211.132.250 80]
Failed to fetch http://ftp.fr.debian.org/debian/dists/woody/main/source/Sources 404 Not Found [IP: 212.27.32.66 80]
Failed to fetch http://ftp.fr.debian.org/debian/dists/woody/non-free/source/Sources 404 Not Found [IP: 212.27.32.66 80]
Failed to fetch http://ftp.fr.debian.org/debian/dists/woody/contrib/source/Sources 404 Not Found [IP: 212.27.32.66 80]
Reading Package Lists... Done
Building Dependency Tree... Done
E: Some index files failed to download, they have been ignored, or old ones used instead.

apt-get install php5-curl
Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package php5-curl
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de xve

Ejecutar Función CURL en PHP con PHP antiguo

Publicado por xve (6548 intervenciones) el 18/12/2017 14:29:49
Hola Enzzo, tienes que cambiar el repositorio, ya que woody, ya no tiene mantenimiento...
Tienes que utilizar:
1
deb http://archive.debian.org/debian/dists/woody/ main contrib non-free

El security ya no existe para esa distribución, ya que como te he comentado, no tiene mantenimiento.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Ejecutar Función CURL en PHP con PHP antiguo

Publicado por Enzzo (20 intervenciones) el 18/12/2017 15:10:26
Gracias xve, lo he cambiado pero me siguen sin dejar:

/etc/apt# cat sources.list


deb http://archive.debian.org/debian/dists/woody/ main contrib non-free

#deb http://ftp.fr.debian.org/debian/ sarge main non-free contrib
#deb-src http://ftp.fr.debian.org/debian/ woody main non-free contrib
#deb http://non-us.debian.org/debian-non-US woody/non-US main contrib non-free
#deb-src http://non-us.debian.org/debian-non-US woody/non-US main contrib non-free

#deb http://security.debian.org/ woody/updates main contrib non-free




#deb-src http://ftp.fr.debian.org/debian/ woody main non-free contrib

/etc/apt# apt-get update
Err http://archive.debian.org main/contrib Packages
404 Not Found [IP: 193.62.202.28 80]
Ign http://archive.debian.org main/contrib Release
Err http://archive.debian.org main/non-free Packages
404 Not Found [IP: 193.62.202.28 80]
Ign http://archive.debian.org main/non-free Release
Failed to fetch http://archive.debian.org/debian/dists/woody/dists/main/contrib/binary-i386/Packages 404 Not Found [IP: 193.62.202.28 80]
Failed to fetch http://archive.debian.org/debian/dists/woody/dists/main/non-free/binary-i386/Packages 404 Not Found [IP: 193.62.202.28 80]
Reading Package Lists... Done
Building Dependency Tree... Done
W: Couldn't stat source package list http://archive.debian.org main/contrib Packages (/var/lib/apt/lists/archive.debian.org_debian_dists_woody_dists_main_contrib_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://archive.debian.org main/non-free Packages (/var/lib/apt/lists/archive.debian.org_debian_dists_woody_dists_main_non-free_binary-i386_Packages) - stat (2 No such file or directory)
W: You may want to run apt-get update to correct these problems
E: Some index files failed to download, they have been ignored, or old ones used instead.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de xve

Ejecutar Función CURL en PHP con PHP antiguo

Publicado por xve (6548 intervenciones) el 18/12/2017 20:15:17
Enzzo, perdona, te lo he puesto mal... prueba así es:
1
deb http://archive.debian.org/debian/ woody main contrib non-free

Disculpa...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Ejecutar Función CURL en PHP con PHP antiguo

Publicado por Enzzo (20 intervenciones) el 18/12/2017 21:46:31
Gracias de nuevo por el tiempo tomado xve. Lo he probado y algo he conseguido, pero sigo sin dar con ello, fíjate el mensaje final:

1
2
3
4
5
6
7
8
9
10
11
apt-get update
Get:1 http://archive.debian.org woody/main Packages [1773kB]           
Get:2 http://archive.debian.org woody/main Release [95B]
Get:3 http://archive.debian.org woody/contrib Packages [49.2kB]
Get:4 http://archive.debian.org woody/contrib Release [98B]
Get:5 http://archive.debian.org woody/non-free Packages [65.7kB]
Get:6 http://archive.debian.org woody/non-free Release [99B]
Fetched 1888kB in 2s (677kB/s)
Reading Package Lists... Done
Building Dependency Tree... Done
E: Some index files failed to download, they have been ignored, or old ones used instead.



1
2
3
4
apt-get install php5-curl
Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package php5-curl
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de xve

Ejecutar Función CURL en PHP con PHP antiguo

Publicado por xve (6548 intervenciones) el 19/12/2017 08:13:13
prueba a buscar el nombre del paquete...
1
apt-cache search php curl
no sea que se llame de otra manera es esa versión de Debian
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Ejecutar Función CURL en PHP con PHP antiguo

Publicado por Enzzo (20 intervenciones) el 19/12/2017 08:59:55
Es extraño pero aunque tiene php 5 al buscar como tú dices solo hace referencia al 4 ?¿?. ¿Pruebo a instalar ese, me valdría (apt-get install php4-curl)?

l~# php -v
PHP Warning: PHP Startup: (null): Unable to initialize module
Module compiled with module API=20020429, debug=0, thread-safety=0
PHP compiled with module API=20050922, debug=0, thread-safety=0
These options need to match
in Unknown on line 0
PHP 5.1.1 (cli) (built: Dec 28 2005 19:28:27)
Copyright (c) 1997-2005 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2005 Zend Technologies

apt-cache search php curl
caudium-php4 - A server-side, HTML-embedded scripting language
php4 - A server-side, HTML-embedded scripting language
php4-cgi - A server-side, HTML-embedded scripting language
php4-curl - CURL module for php4
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de xve

Ejecutar Función CURL en PHP con PHP antiguo

Publicado por xve (6548 intervenciones) el 19/12/2017 12:48:34
La verdad es que es muy extraño que este para la versión 4 y no para la 5...
Prueba a instalar el paquete de la versión 4 haber si te funciona...

Recuerda reiniciar el Apache una vez instalado.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Ejecutar Función CURL en PHP con PHP antiguo

Publicado por Enzzo (20 intervenciones) el 19/12/2017 13:22:20
parece que ha funcionado, ¿sabéis como se reinicia el apache en Debian 3.0?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Ejecutar Función CURL en PHP con PHP antiguo

Publicado por Enzzo (20 intervenciones) el 20/12/2017 11:35:33
lo reinicié pero sigue sin funcionar :-( . Es probable que sea necesario php5-curl sí o sí?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Ejecutar Función CURL en PHP con PHP antiguo

Publicado por Enzzo (20 intervenciones) el 21/12/2017 13:42:58
me quedé atascado, alguien me ayuda? Resumo:
-Por cli veo que tengo (php -v)
PHP 5.1.1 (cli)
-Por phpinfo () cambia:
Apache Version Apache/1.3.37 (Unix) PHP/5.2.1

-Pero luego solo puedo instalar el curl para php4, para php5 me da fallo:
E: Couldn't find package php5-curl

-Con el dpcg veo esto:

dpkg -l *php*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-=====================-=====================-==========================================================
un caudium-php4 <none> (no description available)
un htcheck-php <none> (no description available)
un libphp-adodb <none> (no description available)
un libphp-phplot <none> (no description available)
un mnogosearch-php <none> (no description available)
un php-elisp <none> (no description available)
un php-gtk <none> (no description available)
un php-imlib <none> (no description available)
un php3 <none> (no description available)
un php3-cgi <none> (no description available)
un php3-cgi-database <none> (no description available)
un php3-cgi-gd <none> (no description available)
un php3-cgi-imap <none> (no description available)
un php3-cgi-ldap <none> (no description available)
un php3-cgi-magick <none> (no description available)
un php3-cgi-mhash <none> (no description available)
un php3-cgi-mysql <none> (no description available)
un php3-cgi-pgsql <none> (no description available)
un php3-cgi-snmp <none> (no description available)
un php3-cgi-xml <none> (no description available)
un php3-database <none> (no description available)
un php3-dev <none> (no description available)
un php3-doc <none> (no description available)
un php3-gd <none> (no description available)
un php3-imap <none> (no description available)
un php3-ldap <none> (no description available)
un php3-magick <none> (no description available)
un php3-mhash <none> (no description available)
un php3-msql <none> (no description available)
un php3-mysql <none> (no description available)
un php3-pgsql <none> (no description available)
un php3-snmp <none> (no description available)
un php3-xml <none> (no description available)
ii php4 4.1.2-7.woody4 A server-side, HTML-embedded scripting language
un php4-apc <none> (no description available)
un php4-cgi <none> (no description available)
un php4-cgi-curl <none> (no description available)
un php4-cgi-domxml <none> (no description available)
un php4-cgi-gd <none> (no description available)
un php4-cgi-imap <none> (no description available)
un php4-cgi-ldap <none> (no description available)
un php4-cgi-mcrypt <none> (no description available)
un php4-cgi-mhash <none> (no description available)
un php4-cgi-mysql <none> (no description available)
un php4-cgi-pgsql <none> (no description available)
un php4-cgi-snmp <none> (no description available)
un php4-cgi-xml <none> (no description available)
ii php4-curl 4.1.2-7.woody4 CURL module for php4
un php4-dbase <none> (no description available)
un php4-dev <none> (no description available)
un php4-domxml <none> (no description available)
un php4-gd <none> (no description available)
un php4-gd2 <none> (no description available)
un php4-imap <none> (no description available)
un php4-ldap <none> (no description available)
un php4-mcal <none> (no description available)
un php4-mcrypt <none> (no description available)
un php4-mhash <none> (no description available)
un php4-ming <none> (no description available)
un php4-mysql <none> (no description available)
un php4-odbc <none> (no description available)
un php4-pear <none> (no description available)
un php4-pgsql <none> (no description available)
un php4-recode <none> (no description available)
un php4-sablot <none> (no description available)
un php4-snmp <none> (no description available)
un php4-sybase <none> (no description available)
un php4-xml <none> (no description available)
un php4-xslt <none> (no description available)
un phpdoc <none> (no description available)
un phpgroupware <none> (no description available)
un phpgroupware-addressb <none> (no description available)
un phpgroupware-admin <none> (no description available)
un phpgroupware-api <none> (no description available)
un phpgroupware-api-doc <none> (no description available)
un phpgroupware-bookkeep <none> (no description available)
un phpgroupware-bookmark <none> (no description available)
un phpgroupware-brewer <none> (no description available)
un phpgroupware-calendar <none> (no description available)
un phpgroupware-chat <none> (no description available)
un phpgroupware-chora <none> (no description available)
un phpgroupware-comic <none> (no description available)
un phpgroupware-core <none> (no description available)
un phpgroupware-core-doc <none> (no description available)
un phpgroupware-develope <none> (no description available)
un phpgroupware-dj <none> (no description available)
un phpgroupware-doc <none> (no description available)
un phpgroupware-eldaptir <none> (no description available)
un phpgroupware-email <none> (no description available)
un phpgroupware-filemana <none> (no description available)
un phpgroupware-forum <none> (no description available)
un phpgroupware-ftp <none> (no description available)
un phpgroupware-headline <none> (no description available)
un phpgroupware-hr <none> (no description available)
un phpgroupware-img <none> (no description available)
un phpgroupware-infolog <none> (no description available)
un phpgroupware-inv <none> (no description available)
un phpgroupware-manual <none> (no description available)
un phpgroupware-messenge <none> (no description available)
un phpgroupware-napster <none> (no description available)
un phpgroupware-news-adm <none> (no description available)
un phpgroupware-nntp <none> (no description available)
un phpgroupware-notes <none> (no description available)
un phpgroupware-phonelog <none> (no description available)
un phpgroupware-phpsysin <none> (no description available)
un phpgroupware-phpwebho <none> (no description available)
un phpgroupware-polls <none> (no description available)
un phpgroupware-preferen <none> (no description available)
un phpgroupware-projects <none> (no description available)
un phpgroupware-registra <none> (no description available)
un phpgroupware-setup <none> (no description available)
un phpgroupware-skel <none> (no description available)
un phpgroupware-soap <none> (no description available)
un phpgroupware-stocks <none> (no description available)
un phpgroupware-todo <none> (no description available)
un phpgroupware-transy <none> (no description available)
un phpgroupware-tts <none> (no description available)
un phpgroupware-unstable <none> (no description available)
un phpgroupware-wap <none> (no description available)
un phpgroupware-weather <none> (no description available)
un phpgroupware-xmlrpc <none> (no description available)
un phplib <none> (no description available)
un phplib-dev <none> (no description available)
un phplib-stable <none> (no description available)
un phpmyadmin <none> (no description available)
un phppgadmin <none> (no description available)

¿Alguien me puede echar una mano para poder usar las librerías de curl en php con apache? Gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de xve

Ejecutar Función CURL en PHP con PHP antiguo

Publicado por xve (6548 intervenciones) el 21/12/2017 18:01:34
Hola Enzo, me da la sensación de que tienes el php instalado sin utilizar los paquetes .deb, es decir instalado a mano... descargando los binarios y haciendo la instalación a mano... puede ser?

En el phpinfo(); veras donde se encuentra el php.ini nos puedes adjuntar un pantallazo del php.ini de la parte inicial?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Ejecutar Función CURL en PHP con PHP antiguo

Publicado por Enzzo (20 intervenciones) el 22/12/2017 07:56:07
Hola de nuevo xve, eso creo yo también, pero es algo heredado. Esto me dice el phpinfo():
-Configuration File (php.ini) Path /aplicaciones/php/lib
pero allí no hay nada. El único php.ini que encuentro está en:
-/etc/php4/apache
Realmente con php4 ya me valdría, no necesitaría el 5, el problema es que no sé de cuál está tirando. Te adjunto la salida de este fichero excluyendo comentarios:
cat php.ini |grep -v ";"
[PHP]

engine = On

short_open_tag = On

asp_tags = Off

precision = 14

y2k_compliance = Off

output_buffering = Off

output_handler =

zlib.output_compression = Off

implicit_flush = Off

allow_call_time_pass_reference = On


safe_mode = Off

safe_mode_gid = Off

safe_mode_include_dir =

safe_mode_exec_dir =


safe_mode_allowed_env_vars = PHP_

safe_mode_protected_env_vars = LD_LIBRARY_PATH

disable_functions =

highlight.string = #CC0000
highlight.comment = #FF9900
highlight.keyword = #006600
highlight.bg = #FFFFFF
highlight.default = #0000CC
highlight.html = #000000


expose_php = On


error_reporting = E_ALL & ~E_NOTICE

display_errors = On

display_startup_errors = Off

log_errors = Off

track_errors = Off

warn_plus_overloading = Off


variables_order = "EGPCS"

register_globals = On

register_argc_argv = On

post_max_size = 8M

gpc_order = "GPC"


magic_quotes_gpc = On

magic_quotes_runtime = Off

magic_quotes_sybase = Off

auto_prepend_file =
auto_append_file =

default_mimetype = "text/html"

doc_root =

user_dir =

enable_dl = On

file_uploads = On

upload_max_filesize = 2M

allow_url_fopen = On

[Syslog]
define_syslog_variables = Off

[mail function]
SMTP = localhost

sendmail_from = me@localhost.com


[Logging]

[Java]

[SQL]
sql.safe_mode = Off

[ODBC]

odbc.allow_persistent = On

odbc.check_persistent = On

odbc.max_persistent = -1

odbc.max_links = -1

odbc.defaultlrl = 4096

odbc.defaultbinmode = 1

[MySQL]
mysql.allow_persistent = On

mysql.max_persistent = -1

mysql.max_links = -1

' at MYSQL_PORT.
mysql.default_port =

mysql.default_socket =

mysql.default_host =

mysql.default_user =

mysql.default_password =

[mSQL]
msql.allow_persistent = On

msql.max_persistent = -1

msql.max_links = -1

[PostgresSQL]
pgsql.allow_persistent = On

pgsql.max_persistent = -1

pgsql.max_links = -1

[Sybase]
sybase.allow_persistent = On

sybase.max_persistent = -1

sybase.max_links = -1

sybase.interface_file = "/etc/freetds/interfaces"

sybase.min_error_severity = 10

sybase.min_message_severity = 10

sybase.compatability_mode = Off

[Sybase-CT]
sybct.allow_persistent = On

sybct.max_persistent = -1

sybct.max_links = -1

sybct.min_server_severity = 10

sybct.min_client_severity = 10

[bcmath]
bcmath.scale = 0

[browscap]

[Informix]
ifx.default_host =

ifx.default_user =

ifx.default_password =

ifx.allow_persistent = On

ifx.max_persistent = -1

ifx.max_links = -1

ifx.textasvarchar = 0

ifx.byteasvarchar = 0

ifx.charasvarchar = 0

ifx.blobinfile = 0

ifx.nullformat = 0

[Session]
session.save_handler = files

session.save_path = /tmp

session.use_cookies = 1


session.name = PHPSESSID

session.auto_start = 0

session.cookie_lifetime = 0

session.cookie_path = /

session.cookie_domain =

session.serialize_handler = php

session.gc_probability = 1

session.gc_maxlifetime = 1440

session.referer_check =

session.entropy_length = 0

session.entropy_file =

session.cache_limiter = nocache

session.cache_expire = 180

session.use_trans_sid = 1

url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=fakeentry"

[MSSQL]
mssql.allow_persistent = On

mssql.max_persistent = -1

mssql.max_links = -1

mssql.min_error_severity = 10

mssql.min_message_severity = 10

mssql.compatability_mode = Off


[Assertion]


[Ingres II]
ingres.allow_persistent = On

ingres.max_persistent = -1

ingres.max_links = -1

ingres.default_database =

ingres.default_user =

ingres.default_password =

[Verisign Payflow Pro]
pfpro.defaulthost = "test-payflow.verisign.com"

pfpro.defaultport = 443

pfpro.defaulttimeout = 30


[Sockets]
sockets.use_system_read = On

[com]

[Printer]

[mbstring]

[FrontBase]

extension=curl.so
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Ejecutar Función CURL en PHP con PHP antiguo

Publicado por Enzzo (20 intervenciones) el 24/12/2017 15:39:05
Hola de nuevo. Instalé el resto de paquetes del php4 que aparecian como unistalled en el dkpg y ahora en el phpinfo() ya me sale la version correcta y no me da el error. Sin embargo sigue sin estar habilitado el curl en el mismo phpinfo, si lo compruebo así me sale disable:
echo 'Curl: ', function_exists('curl_version') ? 'Enabled' : 'Disabled';
Estoy atascado, no sé por dónde seguir...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Revisar política de publicidad