PHP - Problema con Symfony 4 y Google (OAuth 2.0)

   
Vista:

Problema con Symfony 4 y Google (OAuth 2.0)

Publicado por Cbastian (6 intervenciones) el 05/02/2018 17:15:00
Hola,

Estoy tratando de realizar un login por autorizaciones de Google, utilizando OAuth 2 y Symfony 4.
Estoy utilizando la dependencia Hybrid_Auth. Trabajando con xammp funciona correctamente pero alli no estoy utilizando Symfony, el problema que identifique es que al crear las credenciales desde console.developers.google.com existe una sección llamada "URIs de redirección autorizados"; en mis primeros ejemplos en los que no utilice Symfony colocaba http://localhost/oauth2/callback.php?hauth.done=Google y funcionaba correctamente.
Pero ahora con symfony estoy colocando la url http://localhost:8000/CallbackExt?hauth.done=Google y al tratar de consumir el API me esta redireccionando a http://localhost/CallbackExt?hauth.done=Google perdiendo el puerto :(

Que puedo hacer en este caso? Solo se esta perdiendo el puerto. Soy nuevo en symfony y no se si este puerto se pueda cambiar para que se ejecute sobre el localhost con puerto 80 (Por defecto) sin que se le deba añadir a la URL.

Agradezco a quienes me puedan ayudar...
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Problema con Symfony 4 y Google (OAuth 2.0)

Publicado por Cbastian (6 intervenciones) el 05/02/2018 18:46:54
Ya lo resolví, por si a alguien le llega a ocurrir lo mismo...

Lo que hice fue cambiar el puerto por el cual se estaba ejecutando el servidor de symfony.

1
php bin/console server:start 127.0.0.1:80

Y así se ejecuta sobre el puerto 80 y ya solo fue cuestión de crear la credencial nuevamente desde developers.google.com y no tuve problemas con redirección ni ninguna otra cosa
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
2
Comentar
Revisar política de publicidad