PHP - Los servicios de Xamp no arrancan

 
Vista:
sin imagen de perfil
Val: 60
Ha aumentado 1 puesto en PHP (en relación al último mes)
Gráfica de PHP

Los servicios de Xamp no arrancan

Publicado por carlos (33 intervenciones) el 16/03/2021 02:39:03
Hola, espero me puedan ayudar. estaba usando el Xamp, pero ahora cuando quiero arrancar el Apache y el MySQL da un error.
Esto aparece en la barra de estado del Xamp:
21:27:36 [main] Initializing Control Panel
21:27:36 [main] Windows Version: Home 64-bit
21:27:36 [main] XAMPP Version: 8.0.0
21:27:36 [main] Control Panel Version: 3.2.4 [ Compiled: Jun 5th 2019 ]
21:27:36 [main] You are not running with administrator rights! This will work for
21:27:36 [main] most application stuff but whenever you do something with services
21:27:36 [main] there will be a security dialogue or things will break! So think
21:27:36 [main] about running this application with administrator rights!
21:27:36 [main] XAMPP Installation Directory: "c:\xampp\"
21:27:36 [main] Checking for prerequisites
21:27:44 [main] All prerequisites found
21:27:44 [main] Initializing Modules
21:27:44 [main] Starting Check-Timer
21:27:44 [main] Control Panel Ready
21:34:36 [main] Executing "c:\xampp\"
21:35:55 [Apache] Status change detected: running
21:35:56 [Apache] Status change detected: stopped
21:35:56 [Apache] Error: Apache shutdown unexpectedly.
21:35:56 [Apache] This may be due to a blocked port, missing dependencies,
21:35:56 [Apache] improper privileges, a crash, or a shutdown by another method.
21:35:56 [Apache] Press the Logs button to view error logs and check
21:35:56 [Apache] the Windows Event Viewer for more clues
21:35:56 [Apache] If you need more help, copy and post this
21:35:56 [Apache] entire log window on the forums

Les comento que el servicio de publicación lo tengo en manual y desactivado, y que además hasta ayer el xamp andaba bien, es mas, lo había configurado para que los servicios arranquen automáticamente.
Bueno gente, ese es mi problema. Desde ya gracias a quien pueda ayudarme.
Saludos cordiales.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de joel
Val: 3.814
Oro
Ha mantenido su posición en PHP (en relación al último mes)
Gráfica de PHP

Los servicios de Xamp no arrancan

Publicado por joel (1264 intervenciones) el 16/03/2021 11:31:24
Hola Carlos, has revisado el log del apache como te indica? haber cual puede ser el problema?
Press the Logs button to view error logs and check
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
Imágen de perfil de Mauro
Val: 2.725
Plata
Ha aumentado 1 puesto en PHP (en relación al último mes)
Gráfica de PHP

Los servicios de Xamp no arrancan

Publicado por Mauro (875 intervenciones) el 16/03/2021 14:27:43
Hola Carlos:

Por lo que puedo ver de los mensajes de error estás intentando iniciar los servicios con un usuario que no tiene los privilegios suficientes... no sé cómo funciona esto en Windows, pero lo que necesitas es iniciar Xampp con un usuario administrador

Exitos!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 60
Ha aumentado 1 puesto en PHP (en relación al último mes)
Gráfica de PHP

Los servicios de Xamp no arrancan

Publicado por carlos (33 intervenciones) el 16/03/2021 18:38:56
Hola Joel, desde ya gracias por responder.
La verdad que no ví esa parte, como dije soy aprendiz, pero ya lo veo; y si hay algo que no entienda, o no sepa que hacer, estaré volviendo para comentarles que dice en el log.
Nuevamente gracias.
Saludos cordiales.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 60
Ha aumentado 1 puesto en PHP (en relación al último mes)
Gráfica de PHP

Los servicios de Xamp no arrancan

Publicado por carlos (33 intervenciones) el 17/03/2021 14:25:43
Hola Mauro, voy a revisar lo que me decís, talvez se cambio el inicio de sesión, y no inicia como administrador.
Joel, revisé el archivo que me indicaste, y hay un par de errores, mucho no los entiendo, salvo algunos que son muy claros. De todas formas, les comparto lo que dice ese archivo:
1
2
3
4
5
6
7
8
[Fri Mar 05 10:47:53.036614 2021] [ssl:warn] [pid 7764:tid 560] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Mar 05 10:47:53.515624 2021] [ssl:warn] [pid 7764:tid 560] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
PHP Warning:  'C:\\WINDOWS\\SYSTEM32\\VCRUNTIME140.dll' 14.0 is not compatible with this PHP build linked with 14.28 in Unknown on line 0
[Fri Mar 05 10:47:53.600252 2021] [:emerg] [pid 7764:tid 560] AH00020: Configuration Failed, exiting
[Fri Mar 05 10:53:40.100213 2021] [ssl:warn] [pid 2880:tid 592] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Mar 05 10:53:40.785064 2021] [ssl:warn] [pid 2880:tid 592] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
PHP Warning:  'C:\\WINDOWS\\SYSTEM32\\VCRUNTIME140.dll' 14.0 is not compatible with this PHP build linked with 14.28 in Unknown on line 0
[Fri Mar 05 10:53:40.790071 2021] [:emerg] [pid 2880:tid 592] AH00020: Configuration Failed, exiting

Como siempre mil gracias.
Saludos cordiales.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Mauro
Val: 2.725
Plata
Ha aumentado 1 puesto en PHP (en relación al último mes)
Gráfica de PHP

Los servicios de Xamp no arrancan

Publicado por Mauro (875 intervenciones) el 17/03/2021 14:33:58
mmm, eso suena a que se corrompió la instalación de XAMP... tal vez te convenga desinstalar todo y volver a instalarlo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de joel
Val: 3.814
Oro
Ha mantenido su posición en PHP (en relación al último mes)
Gráfica de PHP

Los servicios de Xamp no arrancan

Publicado por joel (1264 intervenciones) el 17/03/2021 15:52:53
Estoy de acuerdo con Mauro... hay algún error en la configuración... has tocado algún archivo de configuración manualmente?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Los servicios de Xamp no arrancan

Publicado por carlos (33 intervenciones) el 18/03/2021 13:22:14
Hola, hasta donde yo se, no toqué ningún archivo manualmente, talvez cuando uso el ccleaner, se borró algo, o cambió de lugar.
De todas formas, lo que hice recientemente fue desinstalarlo y volverlo a instalar, luego de ver los errores del archivo que me indicaste, pero sigue igual.
Ya en este punto no se que hacer.
Nuevamente, mil gracias por todo.
Saludos cordiales.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Mauro
Val: 2.725
Plata
Ha aumentado 1 puesto en PHP (en relación al último mes)
Gráfica de PHP

Los servicios de Xamp no arrancan

Publicado por Mauro (875 intervenciones) el 19/03/2021 13:28:08
Tal vez podrías probar con otro software... Laragon por ejemplo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

Los servicios de Xamp no arrancan

Publicado por carlos (33 intervenciones) el 23/03/2021 04:02:06
Hola Mauro, estuve probando Laragon, y ya no tengo problema con apache, mysql, ni php. La verdad que está genial. Mil gracias por tu aporte. Estuve actualizando las versiones de los servicios; ahora el único problema que tengo, es que al escribir en el navegador: "localhost/phpmyadmin" me aparece lo siguiente:
"Prohibido
No tiene permiso para acceder a / phpmyadmin en este servidor.".
Bueno, como soy nuevo en esto, no se que hacer, espero me ayudes, así puedo continuar con lo que venía haciendo.
Nuevamente gracias por el aporte.
Saludos cordiales.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Mauro
Val: 2.725
Plata
Ha aumentado 1 puesto en PHP (en relación al último mes)
Gráfica de PHP

Los servicios de Xamp no arrancan

Publicado por Mauro (875 intervenciones) el 24/03/2021 14:26:14
Hola Carlos:

Que bueno que te haya funcionado :)

Personalmente no me manejo con Laragon ni XAMPP, uso Linux con máquinas virtuales pero encontré este artículo donde explican cómo habilitar phpMyAdmin en Laragon... espero te sirva!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Los servicios de Xamp no arrancan

Publicado por carlos (33 intervenciones) el 25/03/2021 15:57:24
Hola Mauro, nuevamente gracias por tu aporte. El artículo me dió la solución, pero te consulto por si sabés la respuesta. Ahora cuando voy a la página de phpmyadmin me pide usuario y contraseña.
Saludos cordiales.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Mauro
Val: 2.725
Plata
Ha aumentado 1 puesto en PHP (en relación al último mes)
Gráfica de PHP

Los servicios de Xamp no arrancan

Publicado por Mauro (875 intervenciones) el 26/03/2021 02:29:06
Hola Carlos:

Eso puede ser un tema de configuración de http... ¿puede que haya un archivo .htaccess en la raíz del phpMyAdmin?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar