Pseudocódigo/Diagramas de Flujo - Ayuda ordenar alfabéticamente las 27 letras del abecedario. DFD

 
Vista:
sin imagen de perfil
Val: 7
Ha mantenido su posición en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

Ayuda ordenar alfabéticamente las 27 letras del abecedario. DFD

Publicado por Erick (5 intervenciones) el 30/10/2016 11:22:42
Hola.
Necesito ayuda por favor,para ordenar alfabéticamente las 27 letras del abecedario.

Con ayuda de Internet logre hacer un vector que pida 27 veces al usuario ingresar una letra.Si esta repetida le diga al usuario que ingrese una letra distinta pero hay un error sigue con la siguiente posición y deja el campo vació NO VUELVE A PEDIRLE LA LETRA EN ESE CAMPO, y mucho menos he logrado que ordene alfabéticamente las letras. (Claro que si ingreso las 27 letras correctamente funcionaria y faltaria ordenarlo)

Por favor necesito alguien que me ayude a ordenarlo. Tengo entendido que es con 2 for pero no se me ocurre nada, No se si es con el código ASCII de las letras o algún otro método.

Y se que es mucho pedir pero alguien me podría decir que hace cada elemento Exactamente necesito exponerlo y no quiero equivocarme.

Gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
sin imagen de perfil
Val: 7
Ha mantenido su posición en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

Ayuda ordenar alfabéticamente las 27 letras del abecedario. DFD

Publicado por Erick (5 intervenciones) el 31/10/2016 04:56:48
Hola logre Solucionarlo y funciona perfectamente en DFD pero me toca transcribirlo PSeInt Y Me arroja un error

Algoritmo Abecedario2
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
Dimension x[3]
Para i<-1 Hasta 3 Con Paso 1 Hacer
	Escribir "Digite una letra"
	Leer A
	Si i>1 Entonces
		R=0
		Para j<-1 Hasta (i-1) Con Paso 1 Hacer
			Si X[j]=A Entonces
				R=R+1
			Fin Si
		Fin Para
		Si R=0 Entonces
			X[i]=A
		Sino
			Escribir "Letra Repetida"
		Fin Si
	Sino
		X[i]=A
	Fin Si
Fin Para
Para i<-1 Hasta 3 Con Paso 1 Hacer
	Escribir X[i]
Fin Para
 
 
 
 
 
Para i<-1 Hasta 3 Con Paso 1 Hacer
	Para j<-1 Hasta 3 Con Paso 1 Hacer
		Si X[j]>X[j+1] Entonces                                            <------------Error Pero en DFD corre perfectamente
			aux=X[j]
			X[j]=X(j+1)
			X[j+1]=aux
		Fin Si
	Fin Para
Fin Para
Para i<-1 Hasta 3 Con Paso 1 Hacer
	Escribir X[i];
Fin Para


Por favor ayuda
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 7
Ha mantenido su posición en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

Ayuda ordenar alfabéticamente las 27 letras del abecedario. DFD

Publicado por Erick (5 intervenciones) el 31/10/2016 05:32:46
Algoritmo Abecedario2
Dimension x[27]
Para i<-1 Hasta 27 Con Paso 1 Hacer
Escribir "Digite una letra"
Leer A
Si i>1 Entonces
R=0
Para j<-1 Hasta (i-1) Con Paso 1 Hacer
Si X[j]=A Entonces
R=R+1
Fin Si
Fin Para
Si R=0 Entonces
X[i]=A
Sino
Escribir "Letra Repetida"
Fin Si
Sino
X[i]=A
Fin Si
Fin Para
Para i<-1 Hasta 27 Con Paso 1 Hacer
Escribir X[i]
Fin Para

Para i<-1 Hasta 27 Con Paso 1 Hacer
Para j<-1 Hasta 27-1 Con Paso 1 Hacer
Si X[j]>X[j+1] Entonces <------Error Pero en DFD corre perfectamente SOLO ES PONERLE MENOS 1 EN EL FOR ANTERIOR
aux=X[j]
X[j]=X[j+1]
X[j+1]=aux
Sino
Fin Si
Fin Para
Fin Para
Para i<-1 Hasta 27 Con Paso 1 Hacer
Escribir "Ordenado",X[i];
Fin Para
FinAlgoritmo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Rafael Angel
Val: 2
Ha disminuido su posición en 23 puestos en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

Ayuda ordenar alfabéticamente las 27 letras del abecedario. DFD

Publicado por Rafael Angel (1 intervención) el 26/03/2019 02:44:40
También puede servir ordenar por código Ascii ya que A es menor que Z en Ascii.
Son números que van del 0 al 250.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar