Pseudocódigo/Diagramas de Flujo - ayuda con algoritmo y programa

   
Vista:
Imágen de perfil de cesar

ayuda con algoritmo y programa

Publicado por cesar profesorcesar2003@gmail.com (7 intervenciones) el 18/06/2017 23:45:32
una vez hecho el programa me da un error en cual es su problema yo el problema esta en el adjunto ejercicio de lapso Se va a hacer solo parte 1 y el proyecto en pseint en archivo consultas pagos ingreso cardiovascular y me dice que
Ingresa CI
> 123
Ingresa Nombre
> cesu
cual es su problema
> respiratorio
Lin 12 (inst 1): ERROR 120: No coinciden los tipos (PROBL
EMA1
el resto lo hice asi
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
Escribir "Ingresa CI"
        leer CI
        Escribir "Ingresa Nombre"
        Leer Nombre
        Escribir "cual es su  problema"
        Leer problema1, problema2
        problema1 = cardiovascular
        problema2 = resp
        Si problema1 Entonces
                Escribir UD debera pagar 1 * radiografia + 1 * consulta
 
        Sino
                Escribir UD debera pagar 3 * radiografia + 1 * consulta
        Fin Si
                Si problema2 Entonces
                        Escribir UD debera pagar 2 * radiografia + 1 * consulta
                Sino
                        Escribir UD debera pagar 3 * radiografia + 1 * consulta
                FinSi
 
                suma = cardiovascular + resp
                suma2 = radiografia + consulta
                Escribir "El total a pagar es  ",suma2
 
                Escribir "la Cantidad de pacientes con problema cardiovascular es   ",suma
 
                Escribir "la Cantidad de pacientes con problema respiratorio es   ",suma
 
FinAlgoritmo
Adjunto y el problema como tal
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder