Pseudocódigo/Diagramas de Flujo - Error a la hora de mostrar los resultados

   
Vista:
Imágen de perfil de robert

Error a la hora de mostrar los resultados

Publicado por robert (1 intervención) el 29/06/2017 20:26:19
Buenas tardes compañeros, he estado haciendo un algoritmo que multiplica dos matrices NxM, el problema es que a la hora de mostrar los resultados de dicha operación, no son los correctos, dejaré el código a ver si me pueden ayudar a encontrar la falla, gracias.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
Dimension a(100,100),b(100,100),mu(100,100)
	Leer n
	Leer m
	Escribir "________"
	Escribir "matriz 1"
	Para f=1 Hasta n
		para c=1 Hasta m
			Leer a(f,c)
		FinPara
	FinPara
 
	Escribir "matriz 2"
	Leer n1,m1
	Escribir "_____"
 
	para f=1 hasta n1
		Para c=1 hasta m1
			Leer b(f,c)
		FinPara
	FinPara
 
	Escribir "__________"
 
	para f=1 hasta n
		para c=1 Hasta m
 
			mu(f, c) =mu(f,c) + a (f, c) * b(f, c)
			Mostrar mu(f,c)
		FinPara
	FinPara
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Revisar política de publicidad