Pseudocódigo/Diagramas de Flujo - programa que me de cuanto debo pagar si ganancia mayor a un numero y menor a otro numero en pseint

   
Vista:
Imágen de perfil de cesar

programa que me de cuanto debo pagar si ganancia mayor a un numero y menor a otro numero en pseint

Publicado por cesar profesorcesar2003@gmail.com (7 intervenciones) el 12/08/2017 06:00:42
programa que me de cuanto debo pagar si ganancia mayor a un numero y menor a otro numero en pseint
mi proyecto resumen al poner la condicion anidada da error ahora si se puede con for la idea es esa

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
Algoritmo ganancia
	Escribir "escriba un Numero"
	definir ganancia como entero
 
	Si ganancia > 60 o <= 50 Entonces // da un error 
		Escribir "debe pagar Bs 5000 o 7000"
 
	Sino
		Escribir "DEbe pagar 4000"
 
		Si ganancia > 60 o (// o y) <= 80 Entonces // da un error 
			Escribir "debe pagar Bs 8000 y 9000 bs"
 
		Fin Si
		Si ganancia > 80 y (// o y) <= 100 Entonces // da un error 
			Escribir "debe pagar Bs 10000 bs"
		Fin Si
		Si ganancia >  100  Entonces // no da un error 
			Escribir "debe pagar Bs 16000 bs"
		Fin Si
	Fin Si
FinAlgoritmo
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

programa que me de cuanto debo pagar si ganancia mayor a un numero y menor a otro numero en pseint

Publicado por dario (4 intervenciones) el 12/08/2017 12:14:16
No tengo el Pseint, pruebalo asi:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
Algoritmo ganancia
 
	Escribir "escriba un Numero"
 
	definir ganancia como entero
 
	Si ganancia > 60 o ganancia <= 50 Entonces // da un error 
 
		Escribir "debe pagar Bs 5000 o 7000"
 
	Sino
 
		Escribir "DEbe pagar 4000"
 
	Fin Si
 
	Si ganancia > 60 o ganancia <= 80 Entonces // da un error 
 
		Escribir "debe pagar Bs 8000 y 9000 bs"
 
	Fin Si
 
	Si ganancia > 80 y ganancia <= 100 Entonces // da un error 
 
		Escribir "debe pagar Bs 10000 bs"
 
	Fin Si
 
	Si ganancia >  100  Entonces // no da un error 
 
		Escribir "debe pagar Bs 16000 bs"
 
	Fin Si
 
FinAlgoritmo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de cesar

programa que me de cuanto debo pagar si ganancia mayor a un numero y menor a otro numero en pseint

Publicado por cesar profesorcesar2003@gmail.com (7 intervenciones) el 12/08/2017 23:07:41
Cea la cantidad de errores que genera hagalo en c o emn cuaquier leguaje excepto C* ovisual v oero en visual basuc siii
Lin 9 (inst 1): ERROR 48: Identificador no válido (GANANCIA).

Lin 13 (inst 1): ERROR 285: Identificador no válido (GANANCIA)

Lin 13 (inst 1): ERROR 285: Identificador no válido (GANANCIA)

Lin 33 (inst 1): ERROR 285: Identificador no válido (GANANCIA)

Lin 33 (inst 1): ERROR 285: Identificador no válido (GANANCIA)

Lin 45 (inst 1): ERROR 285: Identificador no válido (GANANCIA)

Lin 45 (inst 1): ERROR 285: Identificador no válido (GANANCIA)

Lin 57 (inst 1): ERROR 285: Identificador no válido (GANANCIA)
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Revisar política de publicidad