Pseudocódigo/Diagramas de Flujo - ordenar codigo ascii en psaint

 
Vista:
Imágen de perfil de cesar
Val: 6
Ha aumentado 1 puesto en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

ordenar codigo ascii en psaint

Publicado por cesar (8 intervenciones) el 30/11/2017 03:43:09
SE LES AGRADECE SU AYUDA AL LLEGAR A LINEA 16 Si (vec(x) > vec(x+1)) Entonces me dice que estoy fuera de rango yo le di a n valores de 4 y 5 y en ambas dio el mismo error
dios le pague a quien me ayude

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
Proceso ordenarcareacteresasci
 
Escribir "ingresa el valor de n  "
Leer n
Dimension vec(n)
band =Falso
Para x<-1 Hasta n Hacer
	vec(x) =azar(255)
 
Fin Para
 
	Mientras (band = falso) Hacer
		band = Verdadero
		Para x<- 1 Hasta n Hacer
			Si (vec(x) > vec(x+1))  Entonces
				aux= vec(x)
				vec(x) = vec(x+1)
				vec(x+1) = aux
				band = Falso
 
		Fin Si
	Fin Para
 
 
Fin Mientras
 
 
Para x<-1 Hasta n Hacer
Escribir (caracter) vec(x)
FinPara
 
 
FinProceso
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder