Pseudocódigo/Diagramas de Flujo - Operación con VECTORES PSEINT

   
Vista:

Operación con VECTORES PSEINT

Publicado por Héctor (1 intervención) el 17/01/2018 04:28:59
Saludos.... Quienes puedan ayudarme.
COPIO EL PSEUCODIGO

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
//3) Llenar un vector de N elementos y ordenarlo en forma ascendente.
//El nuevo resultado se tiene que almacenar en un nuevo vector.
 
Proceso Ordenar
	Definir n,i,j,k, temp,vec1, vec2 Como Entero;
	Dimension vec1[200], vec2[200];
 
	Escribir "Ingrese los elementos del vector: ";
		Leer n;
 
		Para i<-1 hasta n Con Paso 1 Hacer
			Escribir "Ingrese el número: ";
			leer vec1[i];
		FinPara
 
		Para i<-1 hasta n con paso 1 hacer
			Para j<-i+1 hasta n con paso 1 hacer
				si vec1[i] > vec1[j] entonces
					temp <- vec1[i];
					vec1[i] <- vec1[j];
					vec1[j] <- temp;
				FinSi
			FinPara
		FinPara
 
		vec2[k] <- vec1[i];
 
		Para k<-1 Hasta n Con Paso 1 Hacer
			Escribir "El segundo vector es: ", vec2[k];
		FinPara
FinProceso

TENGO PROBLEMAS EN ALMACENAR LOS DATOS ORDENADOS EN UN SEGUNDO VECTOR.... O LO ESTOY HACIENDO MAL, NECESITO AYUUUUUUUUDAAAAAAAA. GRACIAS. Me ordena BIEN porque si muestro al VECTOR1(entrada de datos), lo muestra ordenado. Pero necesito almacenar los datos en un SEGUNDO VECTOR ORDENADOS
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder