Pseudocódigo/Diagramas de Flujo - Algoritmo para calificar 40 alumnos

 
Vista:
sin imagen de perfil
Val: 1
Ha disminuido su posición en 9 puestos en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

Algoritmo para calificar 40 alumnos

Publicado por Ruben (2 intervenciones) el 21/06/2018 21:39:52
el programa me pide calificar 40 alumnos ya hice todo me manda error al momento de ejecutar debido a lo de los nombres, nose como hacer para que me impriman los nombres de los 40 alumnos si tengo algo mas malo díganmelo por favor


1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
Proceso programa55
	//escriba un algoritmo para calificar 40 alumnos, el programa debe leer el nombre, sus 4 calificaciones de cada alumno, debe calcular el promedio para cada uno y 
	//despues determinar si el aluno aprobo o no aprobo, se requiere un promedio de 7 minimo para aprobar el curso y la salida debe ser la siguiente: nombre, calificaciones, 
	//promedio, aprobo o no aprobo, indicar cuantos alumnos aprobaron y el numero de ellos que obtuvieron 8 de promedio.
	Definir nom como cadena
	Definir a,x,n,n1,n2,n3,n4,c1,c2,c3,c4,p,z,q,ap,re,och Como Entero
	x=0;
	a=1;
	n=0;
	n1=0;
	n2=0;
	n3=0;
	n4=0;
	p=0;
	z=0;
	q=1;
	ap=0;
	re=0;
	och=0;
	Repetir
		x=x+1;
		a=a+1;
		Escribir "Alumno No. ",a;
		Escribir "Nombre: ",nom;
		n=n+nom;
		Escribir "Calificacion 1: ";
		Leer c1;
		n1=n1+c1;
		Escribir "Calificacion 2: ";
		Leer c2;
		n2=n2+c2;
		Escribir "Calificacion 3: ";
		Leer c3;
		n3=n3+c3;
		Escribir "Calificacion 4: ";
		Leer c4;
		n4=n4+c4;
		prom=((n1+n2+n3+n4)/4);
		p=p+prom;
	Hasta Que x=5;
	Repetir
		z=z+1;
		Escribir "Alumno No. ",q;
		q=q+1;
		Escribir "Nombre: ",n;
		Escribir "Calificacion 1: ",n1;
		Escribir "Calificacion 2: ",n2;
		Escribir "Calificacion 3: ",n3;
		Escribir "Calificacion 4: ",n4;
		Escribir "Promedio: ",p;
		si(p>7)Entonces
			ap=ap+1;
			Escribir "Aprobo";
		SiNo
			si(p<7)Entonces
				re=re+1;
				Escribir "Reprobo";
			SiNo
				si(p=8)Entonces
					och=och+1;
				FinSi
			FinSi
		FinSi
	Hasta Que z=x;
	Escribir "Alumnos aprobados: ",ap;
	Escribir "Alumnos Rerobados: ",re;
	Escribir "Alumnos con promedio de 8: ",och;
 
FinProceso
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de kingk
Val: 4
Ha aumentado su posición en 19 puestos en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

Algoritmo para calificar 40 alumnos

Publicado por kingk (2 intervenciones) el 23/06/2018 01:01:14
El problema es que tratas de sumarle a una variable de tipo numero entero un valor de tipo cadena, no puedes sumar numeros con cadenas. Por otro lado en las variables n1, n2, n3, n4 se ira sumando las calificaciones con las calificaciones de los estudiantes anteriores. Por tanto obtendras el promedio incorrecto.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 37
Ha aumentado su posición en 2 puestos en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

Algoritmo para calificar 40 alumnos

Publicado por dario (4 intervenciones) el 23/06/2018 08:51:11
Te dejo el algoritmo en Pascal.
Salu2.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
uses crt;
const
	alumnos = 3;
type estudiantes = record
	nombre:string;
	cal1,cal2,cal3,cal4:real;
end;
var
	datos:array[1..100] of estudiantes;
	i:byte;
	s,c,promedio:real;
begin
	clrscr;
	for i:=1 to alumnos do begin
		writeln('Alumnos # ',i);
 
		with datos[i] do begin
			write('Nombre: ');
			readln(nombre);
			write('Calificacion 1: ');
			readln(cal1);
			write('Calificacion 2: ');
			readln(cal2);
			write('Calificacion 3: ');
			readln(cal3);
			write('Calificacion 4: ');
			readln(cal4);
			writeln;
		end;
 
	end;
 
	//promedio de cada uno
	for i:=1 to alumnos do begin
		s:=0;
		promedio:=0;
 
		with datos[i] do begin
			writeln('Alumno: ',nombre);
			write('Calificaciones: ');
			write(cal1:4:2,' ',cal2:4:2,' ',cal3:4:2,' ',cal4:4:2);
			writeln;
			c:=(cal1 + cal2 + cal3 + cal4);
			s:=s + c;
			promedio:=s/4;
			writeln('Promedio: ',promedio:4:2);
			if promedio > 6 then
				writeln('Aprobado')
			else
				writeln('No aprobado');
		end;
		writeln;
	end;
end.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Algoritmo para calificar 40 alumnos

Publicado por Ruben rodriguez (2 intervenciones) el 30/06/2018 18:18:48
lo que sale por ejemplos datos[i] son arreglos verdad?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar