Pseudocódigo/Diagramas de Flujo - ayudaaaa es urgente plis

 
Vista:
Imágen de perfil de Misheru
Val: 1
Ha disminuido su posición en 9 puestos en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

ayudaaaa es urgente plis

Publicado por Misheru (1 intervención) el 18/07/2018 01:29:35
tengo una duda y me urge responderla, tendre un examen :(

estamos trabajando con el pseint, y pude hacer la mayor parte creo, pero no sé como hacer que aparezca el nombre de forma correcta correspondiente al mayor y al menor valor :(, este es el problema
Una empresa distribuidora de botanas cuenta con N repartidores , los cuales al final de su jornada laboral entregan un reporte con la venta reaizada. implemente un ciclo para capturar el nombre y la venta (en dinero) de cada repartidor y al final muestre el nombre y la venta de los repartidores con mayor y menor venta

esto tengo por ahora :(

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
Algoritmo vendedores
mayor=0
menor=999999999
 
Escribir "ingrese la cantidad de repartidores"
Leer N
Para x<-1 Hasta N Con Paso 1 Hacer
    Escribir "ingrese su nombre"
    Leer nombre
    Escribir "ingrese su venta"
    Leer venta
 
    Si venta>mayor Entonces
        mayor=venta
 
    SiNo
        menor=venta
 
    Fin Si
Fin Para
 
Imprimir nombre ", es el mejor vendedor, con una venta de:",mayor
Imprimir nombre ", es el peor vendedor, con una venta de:",menor
FinAlgoritmo
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
sin imagen de perfil
Val: 37
Ha aumentado su posición en 2 puestos en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

ayudaaaa es urgente plis

Publicado por dario (10 intervenciones) el 18/07/2018 05:23:58
Espero esto te ayude, es similar a tu codigo pero con algunas correcciones.
Salu2.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
Algoritmo ventasRepartidores
	mayor = 0
 
	Escribir "Numero de repartidores: "
	Leer num
 
	Para i <- 1 Hasta num Hacer
		Escribir "Nombre del repartidor: "
		Leer nombre
		Escribir "Valor de la venta: "
		Leer venta
 
		si venta > mayor Entonces
			mayor = venta
			mnombre = nombre
		SiNo
			menor = venta
			tnombre = nombre
		FinSi
 
	FinPara
 
	Escribir "El mejor vendedor es ",mnombre," con una venta de ",mayor
	Escribir "El peor vendedor es ",tnombre," con una venta de ",menor
 
FinAlgoritmo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar