Pseudocódigo/Diagramas de Flujo - Necesito ayuda, please!!

 
Vista:
Imágen de perfil de Tribulus
Val: 5
Ha aumentado su posición en 2 puestos en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

Necesito ayuda, please!!

Publicado por Tribulus (3 intervenciones) el 12/10/2018 11:23:06
Hola a todos,
estoy empezando con los arrays y tengo que hacer este ejercicio:

// Programar una aplicación que pida al usuario 10 números y los imprima de menor a mayor //

el inicio creo que es el correcto ,

dimension numero[10]

Para i=1 hasta 10 hacer
escribir "introducir 10 números";
leer numero[i];
Fin Para

Para que me imprima los datos creo que tengo otro para

Para k=1 hasta 10 hacer

.....................

ahi me he quedado, muchas gracias!!!!!!!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Dani
Val: 5
Ha aumentado su posición en 2 puestos en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

Necesito ayuda, please!!

Publicado por Dani (3 intervenciones) el 12/10/2018 13:25:43
Voy avanzando
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
Proceso ejercicio10
 
// Una aplicación que pida al usuario 10 números y los//
//devuelve ordenados de menor a mayor//
 
	dimension numero[10]
 
	//Bucle de repetición para que pida los diez números que queremos ordenar//
 
	Para i=1 hasta 10 hacer
 
		escribir "introducir 10 números";
		leer numero[i];
	FinPara
 
 
 
	Para i=1 hasta 10 con paso 1 hacer
 
		Para j<-1+1 hasta 10 con paso 1 hacer
 
			//ordenamos el vector, le indicamos las posiciones de los vectores//
 
			si numero[i]>numero[j] entonces
				temp<-numero[i]
				numero[i]<-numero[j]
				numero[j]<-temp
			FinSi
		FinPara
	FinPara
 
	Para k<-1 hasta 10 con paso 1 hacer
		escribir numero[k];
	FinPara
Fin Proceso
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Dani
Val: 5
Ha aumentado su posición en 2 puestos en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

Necesito ayuda, please!!

Publicado por Dani (3 intervenciones) el 13/10/2018 02:21:04
Bueno lo he sacado al final. Gracias por vuestra ayuda!

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
// Una aplicación que pida al usuario 10 números y los//
//devuelve ordenados de menor a mayor//
 
	dimension numero[10]
 
	//Bucle de repetición para que pida los diez números que queremos ordenar//
 
	Para i=1 hasta 10 hacer
		escribir "introducir 10 números";
		leer numero[i];
	FinPara
 
 
 
	Para i=1 hasta 10 con paso 1 hacer
 
		Para j<-i+1 hasta 10 con paso 1 hacer
 
			//ordenamos el vector, le indicamos las posiciones de los vectores//
 
			si numero[i]>numero[j] entonces
				temp<-numero[i]
				numero[i]<-numero[j]
				numero[j]<-temp
			FinSi
		FinPara
	FinPara
 
	Para k<-1 hasta 10 con paso 1 hacer
		escribir numero[k];
	FinPara
Fin Proceso
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar