Pseudocódigo/Diagramas de Flujo - Ayuda con estructuras selectivas. Alguien quien pueda orientarme con esto?

 
Vista:
Imágen de perfil de Linmar
Val: 2
Ha disminuido su posición en 5 puestos en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

Ayuda con estructuras selectivas. Alguien quien pueda orientarme con esto?

Publicado por Linmar linmarbracho2015@gmail.com (1 intervención) el 13/07/2019 14:32:15
examen
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
sin imagen de perfil
Val: 13
Ha mantenido su posición en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

Ayuda con estructuras selectivas. Alguien quien pueda orientarme con esto?

Publicado por dario (9 intervenciones) el 17/07/2019 05:41:55
Ejercicio # 1.
Te dejo esto por si te ayuda.
Salu2.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
Algoritmo productos
	subtotal = 0
	pv = 0
 
	Imprimir "Codigo del producto: "
	Leer codigo
	Imprimir "Costo base del producto: "
	Leer costo_base
	Imprimir "Cantidad de productos vendidos: "
	Leer cantidad
	Imprimir "Tipo de venta (M-Mayor, D-Detal): "
	Leer tipo_venta
 
	subtotal = cantidad * costo_base
 
	si tipo_venta = 'D' Entonces
		pv = subtotal + (subtotal * 0.30)
	SiNo
		pv = subtotal + (subtotal * 0.15)
	FinSi
 
	Imprimir "El total a pagar es de ",pv," Bs"
FinAlgoritmo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 13
Ha mantenido su posición en Pseudocódigo/Diagramas de Flujo (en relación al último mes)
Gráfica de Pseudocódigo/Diagramas de Flujo

Ayuda con estructuras selectivas. Alguien quien pueda orientarme con esto?

Publicado por dario (9 intervenciones) el 17/07/2019 10:42:35
Ejercicio #2

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
Algoritmo comisiones
	Imprimir "Monto de las ventas: "
	Leer monto
 
	si monto <= 1000 Entonces
		comision = monto * 0.05
	SiNo
		si monto > 1000 y monto <= 2000 Entonces
			comision = monto * 0.10
		SiNo
			comision = monto * 0.15
		FinSi
	FinSi
	Imprimir "El valor de la comision es: ",comision
FinAlgoritmo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar