Pseudocódigo/Diagramas de Flujo - ahorcado en pseint

 
Vista:

ahorcado en pseint

Publicado por Nicolás (1 intervención) el 07/10/2019 03:36:54
Hola , necesito ayuda para resolver el juego del ahorcado, sin usar array.
Gracias!

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
Algoritmo sin_titulo
repetir
	escribir "ingrese una palabra para que otra persona adivine"
	leer pal
	lon=longitud(pal)
	Para ii<-1 Hasta lon Con Paso 1 Hacer
		sub=subcadena(pal,ii,ii)
		Si sub<>" " Entonces
			conc=Concatenar(conc,"*")
		SiNo
		Fin Si
	Fin Para
	escribir "toque cualquier tecla"
    Esperar Tecla
	limpiar pantalla
    escribir "Bienvenido al ahorcado. Ingrese letras tratando de adivinar la siguiente palabra"
	escribir conc
	int<-10
	Repetir
		int=int-1
		escribir "ingrese una letra"
		leer let
		Para i<-1 Hasta lon Con Paso 1 Hacer
			sub=subcadena(pal,i,i)
			Si let=sub Entonces
				conc1=Concatenar(conc1,let)
			SiNo
				conc1=conc1
				conc1=Concatenar(conc1,"*")
			Fin Si
		Fin Para
		escribir conc1
	Hasta Que int=0 o conc1=pal
	Si conc=pal Entonces
		escribir "ganaste"
	SiNo
		escribir "perdiste"
	Fin Si
	escribir "deseas jugar de nuevo? escribe si para continuar y no para salir del juego"
	leer respuesta
hasta que respuesta="no"
escribir "hasta luego!"
FinAlgoritmo
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder