Visual Basic.NET - VS 2010 + Crystal report 13 + Access: al ejecutar reporte pide clave

 
Vista:
Imágen de perfil de alejanddro

VS 2010 + Crystal report 13 + Access: al ejecutar reporte pide clave

Publicado por alejanddro (4 intervenciones) el 26/08/2016 18:59:29
Gente
Migre un proyecto desde
VS 2005 + CR 10 + Access 2007 en Windows 7 64 b compliado para X86

El nuevo entorno
VS 2015 + CR 13 + Access 2013 en windows 10 64 b complicado para "any cpu"

el problema es en el nuevo entorno, al ejecutar los reportes, me pide usuario y clave
la base access no tiene claves

Por favor alguien que haya pasado x esta experiencia, HELP ME !!!!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Wilfredo Patricio Castillo
Val: 1.533
Plata
Ha mantenido su posición en Visual Basic.NET (en relación al último mes)
Gráfica de Visual Basic.NET

VS 2010 + Crystal report 13 + Access: al ejecutar reporte pide clave

Publicado por Wilfredo Patricio Castillo (713 intervenciones) el 27/08/2016 17:44:36
Te fijaste la ruta hacia la BD, esté bien?, ya que muchas veces es por eso, ya que cuando se está desarrollando, la BD de desarrollo tiene una ruta distinta a la de producción, otra cosa también es la cadena de conexión.

Saludos cordiales,
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de alejanddro

VS 2010 + Crystal report 13 + Access: al ejecutar reporte pide clave

Publicado por alejanddro (4 intervenciones) el 29/08/2016 12:43:54
Si claro, le paso la ruta de la base antes de mostrarlo
FormRptAccesosEventos.crAccesosEventos1.DataSourceConnections.Item(0).SetConnection(oSistemaCFG.DirBaseDatos, "", False)
la variable oSistemaCFG.dirBaseDatos tiene el string donde se ubica la base. apenas levanta la aplicacion, obtiene la ruta de BD y aca la guarda, con esta variable se inicializa entre otras cosas la conexion a la BD que se usa en toda la aplicacion, para hacer login, por ejemplo.
La ruta es buena. Este codigo funciona hace varios anios, el problema aparece ahora que migre de entorno y actualice Crystal
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 2
Ha aumentado su posición en 31 puestos en Visual Basic.NET (en relación al último mes)
Gráfica de Visual Basic.NET

VS 2010 + Crystal report 13 + Access: al ejecutar reporte pide clave

Publicado por Jaime E. (1 intervención) el 02/09/2016 22:59:27
Yo tuve el mismo problema con mis reportes en Crystal Report 13 trabajaban muy bien con windows 7, SQL 2008 y VB 2010.

Pero al cambiar a Win10 todo se derrumbo dentro de mi.

Lo que tuve que hacer fue generar reportes llamados TIPIADOS.

Es un poco mas de trabajo pero me solucionó TODAS mis fallas. Creeme estuve mas de 2 meses buscando y probando como solucionar este problema y finalmente esto me ayudo mucho.


Entra a Youtube y busca "Como hacer un reporte usando Crystal Report + Visual Studio 2010"


En este video te explica paso a paso como hacer los reportes TIPIADOS y hacer las conexciones a la base de datos.

Solo es cuestion de que adaptes tus reportes a lo que te explica el video.

Si tienes dudas mandame un mail y nos ponemos en contacto.

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de alejanddro

VS 2010 + Crystal report 13 + Access: al ejecutar reporte pide clave

Publicado por alejanddro (4 intervenciones) el 02/09/2016 23:14:04
si, hace como 2 semanas que ando dando vueltas con este tema
voy a buscar lo que me decis, cualquier cosa te escribo
gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Wilfredo Patricio Castillo
Val: 1.533
Plata
Ha mantenido su posición en Visual Basic.NET (en relación al último mes)
Gráfica de Visual Basic.NET

VS 2010 + Crystal report 13 + Access: al ejecutar reporte pide clave

Publicado por Wilfredo Patricio Castillo (713 intervenciones) el 04/09/2016 05:48:06
He trabajado con crystal reports desde la version 4.2 hasta la de visual studio 2015 y ningún problema, estoy seguro que hay alguna referencia errónea.

Si gustas le echamos una mirada via team viewer cuando gustes y verás que no es nada que no se pueda solucionar rápido.

Saludios cordiales,
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de alejanddro

VS 2010 + Crystal report 13 + Access: al ejecutar reporte pide clave

Publicado por alejanddro (4 intervenciones) el 05/09/2016 20:48:20
Hola Wilfredo
Si dale, acepto tu ayuda via teamviewer.
te contacto x coreo electronico
Gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Robertino
Val: 4
Ha aumentado su posición en 7 puestos en Visual Basic.NET (en relación al último mes)
Gráfica de Visual Basic.NET

VS 2010 + Crystal report 13 + Access: al ejecutar reporte pide clave

Publicado por Robertino (3 intervenciones) el 12/10/2017 14:24:43
Proba bajando el framework del programa al 3.5 (No la version Client)...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar