Visual Basic - ERROR 3426 en tiempo de ejecución

Life is soft - evento anual de software empresarial
 
Vista:

ERROR 3426 en tiempo de ejecución

Publicado por KONTXI (14 intervenciones) el 25/04/2001 12:07:21
Hola, tengo un problemilla y es que en un programa que estoy haciendo utilizo para grabar un registro la siguiente sentencia:

data1.recordset.update
data1.recordset.addnew

se me para en la 1ª línea y me sale el siguiente mensaje:

Error 3426 en tiempo de ejecución. Esta acción fue cancelada por el objeto asociado.

No sé como solucionarlo y el caso es que en algún otro programa lo tengo hecho de la misma manera y no me da ningun error.

Muchas gracias por anticipado.
Saludos. Kontxi.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:ERROR 3426 en tiempo de ejecución

Publicado por Miguel (243 intervenciones) el 25/04/2001 13:17:48
Hola.
El Update es para grabar el registro y tiene que ir siempre después de AddNew o Edit.Si en otro procedimiento anterior a lo que has puesto ya tienes un AddNew o Edit y quieres que te vuelva a grabar otro registro con eso deberías poner

Data1.Recordset.Update
Data1.Refresh
Data1.Recordset.AddNew

Espero que te sirva.
Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:ERROR 3426 en tiempo de ejecución

Publicado por Kevelita (7 intervenciones) el 11/05/2011 16:23:25
Hola... heeeeeeemm no entiendo como es que dices que Update debe ir siempre despues de Addnew y luego pones un ejemplo donde primero escribes Update... a mi tambien me sucede el mismo error de la misma manera.. soy nueva en esto y si consiguieran la manera de resolverlo me ayudaria mucho su intervencio... Gracias... PAZ & BIEN <3
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:SIGUE SIN FUNCIONAR

Publicado por KONTXI (14 intervenciones) el 25/04/2001 13:26:57
Hola, gracias por tu respuesta, pero sigue son funcionar, da igual que ponga primero el data1.recordset.addnew
o que entre ambos ponga el refresh, sigue dando el mismo error.
Si se te ocurre algo agradecería tu ayuda.
MUCHAS GRACIAS. KONTXI
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:SIGUE SIN FUNCIONAR

Publicado por Pedro Luis (878 intervenciones) el 25/04/2001 14:18:09
No lo dices pero me parece que usas DataControl, que debe ser el registro asociado que da el error.
Generalmente suele ser longitudes excesivas para las expecificaciones de un campo o datos de diferente tipo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

http://support.microsoft.com/support/kb/articles/Q

Publicado por Martin {^_^} (127 intervenciones) el 25/04/2001 23:29:41
tel vez aqui puedas encontrar ayuda...
http://support.microsoft.com/support/kb/articles/Q189/6/78.asp
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar