Visual Basic - Problema al ejecutar VB

Life is soft - evento anual de software empresarial
 
Vista:

Problema al ejecutar VB

Publicado por Rosy (51 intervenciones) el 05/10/2005 16:24:30
Hola, estoy utilizando una aplicacion desarrollada con VB 6.0 y BD Access 2002. Ejecuto la aplicacion y todo va bien hasta cuando corro un determinado proceso, el programa no responde y lo tengo que cerrar. Lo curioso que cuando lo ejecuto en ambiente de desarrollo, el proceso se ejecuta bien ¿ qué podria estar ocurriendo ?

Atte,
Rosy
Valparaíso, Chile
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Problema al ejecutar VB

Publicado por cristhian ramirez (7 intervenciones) el 05/10/2005 16:28:28
es posible que sea por la base de datos... VB 6.0 funciona con Access 97 solamente... mira instala el access 97 en una carpeta distinta a la del office y crea la base de datos en acces 97... puede ke te resulte
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:En Serio?

Publicado por Rosy (51 intervenciones) el 05/10/2005 21:31:10
¡¡¡¡¡¡¡ Que no es compatible VB 6 con Access 2002 !!!!!! hasta cuando microsoft hace estas cosas!!!! . Realmente no me equivoco cuando trato de hacerle el quite a todos los productos microsoft, ademas de monopolicos (por lo menos acá en Chile) son malos, es que no puede ser que sean incompatibles. Me he desayunado, que puedo decir, un fiasco!!
De todos modos voy a probar y te cuento cómo me va.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:No puede ser!!

Publicado por Rosy (51 intervenciones) el 05/10/2005 21:52:12
Ahora que lo pienso, no puede ser q sean incompatibles, porque de ser así, tampoco correría cuando ejecuto el proceso en ambiente de desarrollo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
sin imagen de perfil
Val: 7
Ha disminuido su posición en 65 puestos en Visual Basic (en relación al último mes)
Gráfica de Visual Basic

RE:No puede ser!!

Publicado por Carlos Gomez (262 intervenciones) el 06/10/2005 01:17:13
Muy bien Rosy eres muy pila, Cristian te veo grave, microsoft nunca crearia este tipo de conflictos, o si te puedes imaginar la cantidad de demandas que tendrian, por estas bobadas, la gente no compraria los software.

a ver mi amiga rosy te cuentoq eu a mi me ha sucedido eso un par de veces y la verdad generalmente es porque algo en el codigo no funciona bien, posiblemente aveces el orden de los procedimientos crean problemas al compilarse, lo que debes hacer es lo siguiente:
1) ejecuta el Executable y ten en cuenta cuando es que sale el error
2) ejecuta el programa desde el visual basic
3) coloca una pausa en el evento donde se produce el error, esto lo haces ubicando el cursor intermitente del mouse al principio del evento, lluego preciosas la tecla F9, si lo haces bien la primera linea del evento se sombrea de color morado o cafe
4) ejecutas el programa o precionas F5
5)has lo mismo como si estuvieras en el executable
6)intenta cambiar el orden de los procedimientos sin alterar tu programa, es decir cambia el codigo de tal forma que hagas las misma rutina o precedimientos.

creo que eso es todo, por si acaso no le encuentras error alguno, enviame el codigo y miramos como te puedo ayudar, ahora si lo deseas coectate al messenger y te ayudo directamente:

pro_carlosgomez@hotmail.com

suerte colega
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:No puede ser!!

Publicado por Rosy (51 intervenciones) el 06/10/2005 15:45:57
ok, gracias, voy a intentar lo que me indicas y luego te cuento
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:dificil hacer esa prueba

Publicado por Rosy (51 intervenciones) el 06/10/2005 16:37:48
Carlos, intenté hacer lo que me sugeriste pero el probema está en que cuando corro el ejecutable no me aparece ningún error, el programa solo se queda pegado y tengo que detenerlo presionando Ctrl-Alt-Supr y finalizar tarea de manera que no puedo identificar dónde se estaría produciendo el conflicto. Y cuando lo ejecuto en el ambiente de desarrollo de VB, el programa corre sin ningun problema, de manera que aqui tampoco puedo identificar donde se produce el conflicto. ¿¿ podria ser problema de dll ??

Rosy
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema al ejecutar VB

Publicado por torra (2 intervenciones) el 08/10/2005 14:09:12
A ver. Primero tienes que tener instalado el service pack más moderno que tengas. El último service pack del vb6 es el sp6, tanto para el visual basic
como el runtime para distribución.
Sucede que los últimos services pack tienen controles incompatibles entre sí.
Si el error es de automatización y un número negativo muy grande, entonces eso es decido a un control label o textbox que intentas modificar.
por su puesto que vb6 es compatible con access 2002, lo que pasa es que tienes que incluir en referencias el motor jet con DAO 3.60. Si incluyes el 3.51 sólo te vale el access 97, pero no es problema del visual, simplemente que no las dicho al programa las librerias dll correctas con las que trabajar.

No sé si te habrá servido de algo. Espero que sí.

Venga.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:sigue el problema

Publicado por Rosy (51 intervenciones) el 11/10/2005 21:21:34
Gracias Fco por responder. Hice lo que indicaste, instalé el Sp 6, y verifiqué en las referencias si estaba incluido el motor jet DAO 3.60, pero aun asi no me funcionó. Quiero aclarar que el programa funciona, siempre y cuando lo ejecute donde se encuentra el proyecto, es decir, los fuentes. Cuando traslado el ejecutable a otro equipo, deja de funcionar y no me aparece ningun error, solo se queda pegado
Atte
Rosy Gallardo H.
Valparaiso, Chile
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar