Visual CSharp .NET - Problema con Objetos de ReportViewer

 
Vista:
Imágen de perfil de Quasar

Problema con Objetos de ReportViewer

Publicado por Quasar (4 intervenciones) el 21/05/2017 20:13:49
Hola buen día colegas, tengo un problema para generar un reporte con report viewer lo que pasa es que cuando le paso el informe rdlc no me cargan los objetos de datos que son el dataset, table adapter, binding source etc. y solo me pasa con un informe porque los demas cargan esos objetos correctamente. Lo CURIOSO es que el sp que uso para ese informe también lo uso para otro que funciona con normalidad aunque de todos modos ya no me genera los objetos y prefiero no tocarlo, pero bueno quisiera saber porque me da este tipo de problemas ya que ni siquiera me salen los dataset en orígenes de datos, cuando compilo el informe me marca 0 errores y en si toda la compilación 0 errores pero no entiendo como es que esto no quiere funcionar, por favor les agradecería mucho su ayuda, les brindaré cualquier información que soliciten para que entiendan mejor mi problema, gracias.

PD: Cosas que ya he hecho; Limpiar solución,
Generar Solución,
Recopilar solución,
Eliminar el sp del data set, actualizar el linq y volverlo a poner,
eliminar y volver a crear el informe,
volver a crear el form de presentación e intentar otra vez enlazar el report viewer,
Crear un Data Set exclusivo para ese informe.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
sin imagen de perfil

Problema con Objetos de ReportViewer

Publicado por jose francisco (12 intervenciones) el 17/06/2017 07:12:37
mm bueno me gustaria ver el codigo que tienes o sino me lo puedes mandar a mi correo josepalominolau@gmail.com, el problema puede ser que no enlazas bien el dataset del rdlc, cuando creas el rdlc y creas una tabla esta te pide que hagas una conexion con tu base de datos, voy a suponer que usas sql server entonces al hacer esto ya te cargan todos los datos de lo que quieres hacer, luego aparte de ello viene el databind para el controlador del reportviewer, personalmente yo hago esta parte por codigo y no por el asistente ya que me ayuda a poder poner parametros para crear filtros, a lo mejor el problema puede ser que no estas cargando los datos del dataset correctos en el controlador del reportviewer, me avisas de todas maneras son gusto te apoyare con tu problema.
un saludo Jose
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar