AJAX - problema al llamar archivo .php con ajax

   
Vista:

problema al llamar archivo .php con ajax

Publicado por robin (1 intervención) el 30/09/2010 15:50:15
Buenos dias

Estoy iniciando por el mundo de ajax y no se si sea muy tribial el inconveniente que tengo pero tratare de ser lo mas explicito para que me entiendan y me puedan colaborar

funcion eliminar_plu
[HIGHLIGHT="Javascript"]function eliminar_plu(prdPlu, empEmpresa, bodBodega, dptDeposito, ord_reconteo){

var recuperacion = 'eliminar_ubicacion';

var ajax=nuevoAjax();

ajax.open("GET", "guardar_ubicacion.php?empEmpresa="+empEmpresa+"&bodBodega="+bodBodega+"&dptDeposito="+dptDeposito+"&prdPlu="+prdPlu+"&ord_reconteo="+ord_reconteo+"&recuperacion="+recuperacion, true);

//ajax.onreadystatechange=function()
// {
// if (ajax.readyState==4)
// {
// selectDestino.parentNode.innerHTML=ajax.responseText;
// }
// }
ajax.send(null);

mostarAsignarplu2();

funcion guardar_plu
}[/HIGHLIGHT]
[HIGHLIGHT="Javascript"]
function guardar_plu(prdPlu){
var tecla = window.event.keyCode;
if (tecla==13) {

var empEmpresa = window.select_empresa.value
var bodBodega = window.select_bodega.value
var dptDeposito = window.select_deposito.value
var ord_reconteo = window.dpu_ordinal.value

var recuperacion = 'nombrecom_nround_ubi';

var ajax=nuevoAjax();

ajax.open("GET", "guardar_ubicacion.php?empEmpresa="+empEmpresa+"&bodBodega="+bodBodega+"&dptDeposito="+dptDeposito+"&prdPlu="+prdPlu+"&ord_reconteo="+ord_reconteo+"&recuperacion="+recuperacion, true);
//ajax.onreadystatechange=function()
// {
// if (ajax.readyState==4)
// {
// selectDestino.parentNode.innerHTML=ajax.responseText;
// }
// }
ajax.send(null);

window.prdPlu.value = ''
mostarAsignarplu2();
}
}[/HIGHLIGHT]

[PHP]<?php
include "conexion2.php";
$empEmpresa =$_GET["empEmpresa"];
$bodBodega =$_GET["bodBodega"];
$dptDeposito =$_GET["dptDeposito"];
$prdPlu =$_GET["prdPlu"];
$ord_reconteo = $_GET["ord_reconteo"];
$recuperacion = $_GET["recuperacion"];

if ($recuperacion == 'nombrecom_nround_ubi'){

$SQL="SELECT pro_producto, dpc_disenocom, dpc_colorcom, cal_calidad, ubi_ubicacion, cub_nrocajon, une_undempaque, und_undmedida, pru_nrounidades FROM sai_productoporubi where emp_empresa = '$empEmpresa' and bod_bodega = '$bodBodega' and dpt_deposito = $dptDeposito and prd_plu = $prdPlu and pru_nrounidades > 0";
$consulta=pg_query($conexion, $SQL) or die(pg_error());
$row= pg_num_rows($consulta);

if ($row == 1){
while($registro=pg_fetch_array($consulta))
{
$pro_producto =$registro[0];
$dpc_diseno = $registro[1];
$dpc_color = $registro[2];
$cal_calidad = $registro[3];
$ubi_ubicacion = $registro[4];
$cub_nrocajon = $registro[5];
$une_undempaque = $registro[6];
$und_undmedida = $registro[7];
$pru_nrounidades =$registro[8];
}
}

$SQL="INSERT INTO sai_reconteoplu (emp_empresa, bod_bodega, dpt_deposito, pro_producto, dpc_disenocom, dpc_colorcom, cal_calidad, une_undempaque, und_undmedida, prd_plu, ubi_ubicacion, cub_nrocajon, dpu_nrounidades, dpu_ordinal)
VALUES('$empEmpresa','$bodBodega', $dptDeposito, $pro_producto, '$dpc_diseno', '$dpc_color', '$cal_calidad', $une_undempaque, $und_undmedida, $prdPlu, $ubi_ubicacion, $cub_nrocajon, $pru_nrounidades, $ord_reconteo) ";
$consulta=pg_query($conexion, $SQL) or die(pg_error());
};

if ($recuperacion == 'eliminar_ubicacion'){
$SQL="DELETE FROM sai_reconteoplu where emp_empresa = '$empEmpresa' and bod_bodega = '$bodBodega' and dpt_deposito = $dptDeposito and prd_plu = $prdPlu and dpu_ordinal = $ord_reconteo";
$consulta=pg_query($conexion, $SQL) or die(pg_error());
}

?>[/PHP]

El problema es el siguiente

La funcion de js guardar plu, recibe unos parametros los cuales llaman a guardar_ubicacion.php, se envia con unos parametros, esta funcion ya los recibe y segun un parametro enviado elimina o guarda, en este caso guardamos, y hasta hay me funciona perfecto.

Tambien hay otra funcion js que eliimina lo que se ha grabado con la anterior explicacio y me funciona perfecto, el caso es que la llamo a guardar_ubicacion.php, envio sos parametros y segun sea el caso de unos de ellos elimina o guarda, en este caso esta eliminando, hasta hay todo normal

El problema esta aca, cuando quiero ingresar nuevamente el elemento que borre anteriormente, es decir, lo agregue y funciono, lo borre y funciono, pero lo voy a agregar nuevamente no me funciono, por lo que logro ver en el debug ni se inmuta para crear nuevamente el objeto de ajax.

Diria yo en medio de mi ignorancia que el objeto no se borro, que si se creo ya no se vuelve a crear con los mismos parametros. En fin,

Agradeceria si alguien me puede colaborar y me dijera como hacer que me guarde, nuevamente lo eliminado.

Si de casualidad no fui claro díganmelo ....
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
información
Otras secciones de LWP con contenido de AJAX
- Código fuente de AJAX
- Cursos de AJAX
- Temas de AJAX
información
Códigos de AJAX
- Autocompletar2
- Autocompletar
- Número aleatorio automatico