ASP.NET - Usar Control AJAX en aplicacion ASP.NET 2.0

   
Vista:

Usar Control AJAX en aplicacion ASP.NET 2.0

Publicado por Marian (8 intervenciones) el 05/02/2009 17:31:15
Buenos días ,
Estoy empezando una aplicacion en ASP.NET, pero ya tengo algunas cosas hechas, me he dado cuenta que necesito usar un control de AJAX, concretamente el DropDownExtender.
Si alguien me puede indicar cuales son los pasos a seguir , le estoy muy agradecida.
La explicación si es posible que sea para torpes, porque me estreno en ASP.NET.
Muchas gracias de antemano.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de roger

RE:Usar Control AJAX en aplicacion ASP.NET 2.0

Publicado por roger (311 intervenciones) el 05/02/2009 18:20:04
primero debes descargar e instalar las extensiones de AJAX, luego puedes descargar el ajaxcontrol toolkit de microsoft, donde esta el control que necesitas.
Merjor Mira este enlace: http://www.es-asp.net/tutoriales-asp-net/tutorial-0-5312/asp-net-ajax-control-toolkit.aspx
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Usar Control AJAX en aplicacion ASP.NET 2.0

Publicado por Marian (8 intervenciones) el 06/02/2009 09:27:17
Muchas gracias Roger,
Ya me había instalado las extensiones AJAX y el control del que me hablas, pero creo que el problema radica en el Framework, ya que tenía instalado la versión 2.0 cuando empecé la aplicacion y posteriormente instalé la version 3.5. El error que me sale al poner el el control es el siguiente:
Error 1 Se está haciendo referencia indirecta al ensamblado System.Web.Extensions, versión 3.5.0.0, que contiene 'AjaxControlToolkit.DropDownExtender'. Este proyecto hace referencia a una versión anterior de System.Web.Extensions, versión 1.0.61025.0. Para utilizar 'AjaxControlToolkit.DropDownExtender', debe reemplazar la referencia a System.Web.Extensions por la versión 3.5.0.0 o una versión posterior.

¿Me puedes decir que es lo que tengo que cambiar?
Muchisimas gracias .

Marian
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de roger

RE:Usar Control AJAX en aplicacion ASP.NET 2.0

Publicado por roger (311 intervenciones) el 07/02/2009 02:31:05
pues creo que las referencias de las extensiones de ajax, se encuentran en el archivo web.config, fijate las versiones que se estan usando y cambialas por las correctas segun el mensaje que te aparece, o fijate en la carpeta bin, donde estan las DLL y mira la version que tienen
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Usar Control AJAX en aplicacion ASP.NET 2.0

Publicado por thomas (1 intervención) el 19/02/2009 16:13:31
Hola, por favor tambien tengo el mismo problema, al usar los controles Ajax, indica que debo usar el framework 3.5... y no el framewor 1.0

Descripción: Error durante la compilación de un recurso requerido para dar servicio a esta solicitud. Revise los detalles de error específicos siguientes y modifique el código fuente en consecuencia.

Mensaje de error del compilador: BC32206: Se está haciendo referencia indirecta al ensamblado System.Web.Extensions, versión 3.5.0.0, que contiene 'AjaxControlToolkit.CalendarExtender'. Este proyecto hace referencia a una versión anterior de System.Web.Extensions, versión 1.0.61025.0. Para utilizar 'AjaxControlToolkit.CalendarExtender', debe reemplazar la referencia a System.Web.Extensions por la versión 3.5.0.0 o una versión posterior.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar