ASP.NET - Problemas al traer imágenes con image.imageurl

   
Vista:

Problemas al traer imágenes con image.imageurl

Publicado por Curiel (1 intervención) el 27/10/2010 02:20:37
Hola a todos, Tengo un problema desde hace varios dias y no puedo solucionarlo al mostrar imagenes usando image.imageurl utilizando Visual.net.

Lo que hago es traer de una base de datos el PATH donde se encuentra alojada la imagen, la guardo en una variable y usando esta variable la muestro usando image.imageurl.

Mi pregunta es si se debe usar alguna propiedad para mostrar imágenes. Estoy utlizando imágnes .JPG algunas imágenes si las muestra pero hay otras del mismo formato que no lo hace. Todas son .JPG. Por favor si hay alguien que me puede ayudar por favor ayudenme.

Les agradezco su atención y su ayuda.

Saludos a todos. Gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de roger

RE:Problemas al traer imágenes con image.imageurl

Publicado por roger (311 intervenciones) el 27/10/2010 05:12:45
pero no entiendo bien cual es el problema, cuando se muestran las imagenes y cuando no?, sabes porque no se muestran en ocasiones?, la propiedad para el control image de asp.net es imageUrl

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problemas al traer imágenes con image.imageurl

Publicado por Khristian (335 intervenciones) el 27/10/2010 15:04:53
En ejecucion pon el raton sobre la imagen, y observa en la barra de estado del exporador la direccion a la que hace referencia, y corrige conforme a ello.

Puedes que estes armando mal la URL.
http://geeks.ms/blogs/sergiotarrillo/archive/2006/11/26/6780.aspx

Si estas usando master page tambien afecta en la forma de indicar la URL de la imagen.

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problemas al traer imágenes con image.imageurl

Publicado por Curiel (2 intervenciones) el 27/10/2010 19:40:41
Estoy utilizando un master page, de qué forma puede afectar y qué puedo hacer para corregirlo o qué propiedad puedo usar?

Gracias por sus respuestas y Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problemas al traer imágenes con image.imageurl

Publicado por Curiel (2 intervenciones) el 27/10/2010 23:33:00
Hola Khristian, te explico... estoy trayendo de una consulta 6 registros aleatorios, un dato de cada registro tiene un path donde se encuentran ubicadas las imagenes.

El caso es que cuando traigo los registros llamo a un método, que me asigna en image en la propiedad imageurl, el path con el nombre de la imagen que en mi caso utilizo sólo JPG, me explico?

Aquí algunas imagenes las muestra otras no, no se en que consiste pues son del mismo tipo de imagen JPG.

Por más que le busco no le encuentro la solución.

Saludos y gracias!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problemas al traer imágenes con image.imageurl

Publicado por khristian (335 intervenciones) el 02/11/2010 01:52:15
Usa el path a la raiz de sitio en las imagenes, asi evitaras que dependiendo de donde este la master page, dependa donde esten las imagenes.

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problemas al traer imágenes con image.imageurl

Publicado por Daniel (1 intervención) el 16/11/2010 23:56:16
Hola ....me esta pasando exactamente lo mismo...al imageurl le estoy asignando la ruta donde están las imágenes. Pero al momento de correr el proyecto no carga las imágenes pero si un icono pequeño. Todas las imágenes son .jpg.......alguien a podido solucionarlo???

Este es el fragmento de código que utilizo para asignarle la dirección al imageurl:

Private Function MontarImagen(ByVal codigo As Integer) As String
Dim RutaArchivo As String = ""
Dim NombreArchivo As String = ""
NombreArchivo = "LGM-" & codigo & ".jpg"
RutaArchivo = Path.Combine(DirDocumento, NombreArchivo)
Return RutaArchivo
End Function


Ayuda pls.. ! ! ! !
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problemas al traer imágenes con image.imageurl

Publicado por Adolfo Luna Sánchez adolus@hotmail.com (1 intervención) el 30/08/2012 23:17:49
Aunque ya es un post algo viejo, les comento que el problema está en colocar toda la ruta del archivo de imagen. Solo pongan el nombre de la imagen pero sin precederlo de la ruta. Asp asume que por defecto está dentro de la carpeta de la solución y solo basta con indicar el nombre del archivo, sin la ruta.
De igual modo si las imágenes se encuentran dentro de una subcarpeta, ésta se debe colocar dentro del directorio del sitio web. Ahi si se tendría que indicar así: "nombre_subcarpeta/imagen.extension"


Espero le sirva todavía a alguien.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problemas al traer imágenes con image.imageurl

Publicado por Osmar Monteagudo (1 intervención) el 17/08/2015 04:05:06
Yo tengo el mismo problema
aunque coloco el nombre del archivo completo
la ruta del archivo es correcta, pero no refresca o actualiza, ni muestra, cunado copio las imagenes a la ruta del proyecto funciona, pero cuando deseo usar otra ruta no lo hace. probe con el disco d:

Protected Sub ListBox1_SelectedIndexChanged(sender As Object, e As EventArgs) Handles ListBox1.SelectedIndexChanged
Image1.ImageUrl = "c:\fotos\" & ListBox1.SelectedValue

End Sub
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problemas al traer imágenes con image.imageurl

Publicado por Joshua (1 intervención) el 16/07/2016 00:31:22
Yo tengo un problema casi similar.

Pongo un texbox en mi formulario aspx y coloco la la dirección de la imagen en la propiedad imageURL al momento de montar el sitio web en el iis y entrar a la pagina no me deja ver ninguna imagen.

Espero me ayuden.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar