ASP.NET - consulta clase...¡¡¡¡

   
Vista:

consulta clase...¡¡¡¡

Publicado por mario martin (4 intervenciones) el 02/11/2007 17:59:38
hola =)
una consulta estoy trabajando en visual studio .net 2005 en web, y la consulta que tengo es:
estoy trabanjo con una clase prueba y en esta quiero realizar mi consulta, al realizar la consulta le agrego un where CodTrab= '" & default.TextBox1.Text & ", pero me sale un error en el textbox1 ????????? esa es mi duca como haria para que si me reconosca.
en el caso de una aplicacion windows yo lwe colocaba el nombre del FORM.TEXTBOX1.TEXT y si me reconocia .

¿como haria en web?
gracias

public class prueba
Public Shared Function GetConsult() As String
Dim consulta = "SELECT codtrab FROM trabajadores where
CodTrab= '" & default.TextBox1.Text & "'"
Dim dbvalue As Object
Using connection As OleDbConnection = Conexion.GetConnection_Planilla()
connection.Open()
Dim com As New OleDbCommand(Consulta, connection)
Dim rea As OleDbDataReader
rea = com.ExecuteReader
If rea.Read() Then
dbvalue = Convert.ToString(rea.GetValue(0) )
end if
end using
end class
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:consulta clase...¡¡¡¡

Publicado por Sebaatian Cruz (4 intervenciones) el 03/11/2007 18:27:58
La clase que comentas es una clase independiente, o es parte de un web form ? por que si es una clase independiente pude que te falten la directiva System.Web.UI.Webcontros y por eso no te reconosca el textbox.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:consulta clase...¡¡¡¡

Publicado por mario martin (4 intervenciones) el 05/11/2007 19:07:08
si es una clase independiente.........., pero no me sale....¡¡¡¡¡¡¡ =)
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:consulta clase...¡¡¡¡

Publicado por Sebastian Cruz (4 intervenciones) el 06/11/2007 15:00:00
tendrias que fijarte si le enviaste a la clase el textbox como parametro. Aunque ayudaria mucho que pudieses poner el codigo que te trae el problema para ver cual podria ser la causa del mismo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar