Access - botones de comando en formulario

   
Vista:

botones de comando en formulario

Publicado por nerea (10 intervenciones) el 17/09/2008 12:33:23
hola a todos... resulta que me han cambiado la versión al access 2007 y me ocurre lo siguiente:

tengo un formulario. le añado dos botones de comandos con el asistente muy sencillitos (nuevo registro y eliminar)

Pero no funcionan!!! los pulso y no hacen nada.

Sabéis por qué? Socorro! help!

Besos, Nere
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:botones de comando en formulario

Publicado por LEONARD (58 intervenciones) el 17/09/2008 14:56:28
Prueba primero has una copia y cambia la version de la base de datos a access 2007, el sistema deberia ajustar todos lo comandos

saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de J. FERnando Pérez Espino

RE:botones de comando en formulario

Publicado por J. FERnando Pérez Espino (1 intervención) el 04/11/2008 15:40:30
Mira, no te funcionan por los niveles de seguridad que maneja Access 2007, lo que debes hacer es deshabilitar algunas características de seguridad poniéndo en riesgo quiza un poco tu información...

El código de los botones, para Access es una macro y automáticamente lo deshabilita, entonces lo que hay que hacer es deshabilitar la característica de access que hace eso. Para esto,

0.- Abre la base de datos que estas manejando y en la que no le funcionan los botones.
1.- Entra al ícono que sistituye al menu archivo en Access 2007 (el ícono de office en la parte superior izquierda)
2.- Accede al botón "Opciones de Access"
3.- Accede en el panel izquierdo a la opción "Centro de confianza"
4.- Da clic en el botón "Configuración del centro de confianza"
5.- Selecciona la última opción, la que habilita todas las macros y luego da clic en Aceptar...

Luego de esto cierra ACCESS y vuelve a abrir tu base de datos, ahora los botones de los formularios deben funcionar a la perfección...

Hasta pronto!!!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

RE:botones de comando en formulario

Publicado por carlos mario (1 intervención) el 11/11/2008 02:16:38
Gracias Fernando, justo lo que estaba buscando en este momento
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:botones de comando en formulario

Publicado por Sergio (1 intervención) el 22/06/2009 16:41:58
Hermano bacano gracias por la información, me sirvio muchisimo, era precisamente lo que estaba necesitando.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:botones de comando en formulario

Publicado por Danny Pastor Urbano  (1 intervención) el 28/10/2009 02:25:17
muchisimas gracias por la info J. FERnando Pérez Espino, ya no sabia que hacer con estos botones, me tenian loco.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:botones de comando en formulario

Publicado por Jose (1 intervención) el 12/11/2009 21:38:58
Hola Fernando, a mi me pasa con el Access 2000. No me funcionan los botones de comando, habiendolos puesto con el asistente.
Si me pudieras ayudar te lo agradecería mucho.
Espero tu respuesta.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:botones de comando en formulario

Publicado por Christiam (1 intervención) el 16/06/2014 16:06:45
Chochera Fernando, te pasaste! Justo estaba buscando cómo solucionar el mismo problema. Gracias.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar