Access - formula en excel-acces

   
Vista:

formula en excel-acces

Publicado por Claudio Senel (4 intervenciones) el 10/10/2008 23:21:10
Estimados

como puedo hacer esta formula de excel en access, es para asignar un n a cada grupo de registros, hice esa consulta ayer pero no respondieron. la formula es =SI(C3=C2;B2;B2+1)
la escribí en la columna B, la tabla tiene la columna A Y C Y mediante consulta quiero agregar estos numeros a partir desde 1, cada vez que ejecute la conulta.

A B C
Mes GRUPO Razon Social
3 1 JUANITO.
3 1 JUANITO.
5 2 CORPORACION.
5 3 JUAN PEREZ
6 4 AGRICOLA
6 5 TELEFONOS

Se despide atentamente,

CSM
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:formula en excel-acces

Publicado por mi menda (1111 intervenciones) el 11/10/2008 12:47:10
Hola Claudio:
En access se usa la función SiInm(Expresión a evaluar;valor para verdadero;valor para falso)
Podría ser más o menos así:
SiInm([Razon Social] = Ùltimo([Razon Social];Último([Grupo]);Nz(Ùltimo([Grupo])+1)+1)
Aunque sí lo vas a utilizar en una consulta de actualización, quizas no funcione y en ese caso sería mejor hacerlo con DAO.

Dim rst As DAO.Recordset
Dim strRsocial As String

Set rst = Currentdb.OpenRecordset("select * from NombreTabla order by [Razon Social]")
rst.MoveLast
rst.MoveFirst

strRsocial = rst![Razon Social]

With rst
While Not .EOF
.Edit
if IsNull(!GRUPO) Then
if strRSocial = ![RazonSocial] Then
!GRUPO = Nz(DLookup("GRUPO","NombreTabla","[Razon Social] = '" & strRSocial & "'"),1)
Else
!GRUPO = Nz(Max(!GRUPO))+1
End if
End If
strRsocial = ![Razon Social]
.Update
.MoveNext
Wend
End With

rst.Close
Set rst = Nothing

Un saludo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar